0

I have tried multiple tutorials on how to setup wifi on my Raspberry Pi 2 but none have worked. New to Linux, hoping someone can help.

When I highlight my network connection in the toolbar I see enxb827ebd72440:: Configured wlx9cefd5fcb786: not associated

I have run

sudo apt-get update
sudo apt-get upgrade
sudo apt-get autoremove
sudo reboot

lsusb

Bus 001 Device 004: ID 148f:5370 Ralink Technology, Corp. RT5370 Wireless Adapter

lsmod

rt2800usb              28672  0
rt2800lib             102400  1 rt2800usb
rt2x00usb              24576  1 rt2800usb
rt2x00lib              57344  3 rt2800lib,rt2800usb,rt2x00usb
mac80211              659456  3 rt2800lib,rt2x00lib,rt2x00usb
cfg80211              573440  2 rt2x00lib,mac80211
rfkill                 28672  2 cfg80211
crc_ccitt              16384  1 rt2800lib

/etc/network/interfaces

source-directory /etc/network/interfaces.d

auto lo
iface lo inet lopback
iface eth0 inet manual
allow-hotplug wlan0


auto wlan0
iface wlan0 inet manual
        wpa-ssid *****
        wpa-psk *****

wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

ifconfig

enxb827ebd72440: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.24  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::a12a:3903:76f5:4699  prefixlen 64  scopeid 0x20<link>
        ether b8:27:eb:d7:24:40  txqueuelen 1000  (Ethernet)
        RX packets 407  bytes 269222 (262.9 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 411  bytes 59567 (58.1 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlx9cefd5fcb786: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 9c:ef:d5:fc:b7:86  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wpa_supplicant

crtl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
ssid="****"
psk="****"
}

iwconfig

wlx9cefd5fcb786  IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=20 dBm   
          Retry short  long limit:2   RTS thr:off   Fragment thr:off
          Power Management:off

lo        no wireless extensions.

enxb827ebd72440  no wireless extensions.

sudo ifup wlan0

ifup: /etc/network/interfaces:10: unknown or no method and no inherits keyword specified
ifup: couldn't read interfaces file "/etc/network/interfaces"

I tried downloading the RT5370 driver but when I try to "make" it I get

sudo make

make -C tools
make[1]: Entering directory '/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools'
gcc -g bin2h.c -o bin2h
make[1]: Leaving directory '/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools'
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/tools/bin2h
cp -f os/linux/Makefile.6 /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/Makefile
make -C /lib/modules/4.14.98-v7+/build SUBDIRS=/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux modules
make[1]: Entering directory '/usr/src/linux-headers-4.14.98-v7+'
  CC [M]  /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.o
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c: In function ‘RtmpPrepareHwNullFrame’:
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:3142:34: error: passing argument 2 of ‘hex_dump’ from incompatible pointer type [-Werror=incompatible-pointer-types]
    hex_dump("null frame before", &longValue, 4);
                                  ^
In file included from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rt_config.h:66:0,
                 from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:28:
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rt_os_util.h:679:6: note: expected ‘unsigned char *’ but argument is of type ‘UINT32 * {aka unsigned int *}’
 void hex_dump(char *str, unsigned char *pSrcBufVA, unsigned int SrcBufLen);
      ^~~~~~~~
In file included from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rtmp_os.h:44:0,
                 from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rtmp_comm.h:69,
                 from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rt_config.h:33,
                 from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:28:
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/os/rt_linux.h:787:29: warning: passing argument 2 of ‘RTUSBReadMACRegister’ makes integer from pointer without a cast [-Wint-conversion]
  RTUSBReadMACRegister((_A), (_R), (PUINT32) (_pV))
                             ^
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:3150:4: note: in expansion of macro ‘RTMP_IO_READ32’
    RTMP_IO_READ32(pAd, pAd->NullBufOffset + TXWISize+ i, &longValue);
    ^~~~~~~~~~~~~~
In file included from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rt_config.h:61:0,
                 from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:28:
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rtmp.h:7214:10: note: expected ‘USHORT {aka short unsigned int}’ but argument is of type ‘USHORT * {aka short unsigned int *}’
 NTSTATUS RTUSBReadMACRegister(
          ^~~~~~~~~~~~~~~~~~~~
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:3151:33: error: passing argument 2 of ‘hex_dump’ from incompatible pointer type [-Werror=incompatible-pointer-types]
    hex_dump("null frame after", &longValue, 4);
                                 ^
In file included from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rt_config.h:66:0,
                 from /home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:28:
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/include/rt_os_util.h:679:6: note: expected ‘unsigned char *’ but argument is of type ‘UINT32 * {aka unsigned int *}’
 void hex_dump(char *str, unsigned char *pSrcBufVA, unsigned int SrcBufLen);
      ^~~~~~~~
/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.c:3021:8: warning: unused variable ‘MlmeRate’ [-Wunused-variable]
  UCHAR MlmeRate;
        ^~~~~~~~
cc1: some warnings being treated as errors
scripts/Makefile.build:326: recipe for target '/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.o' failed
make[2]: *** [/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux/../../common/cmm_data.o] Error 1
Makefile:1535: recipe for target '_module_/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux' failed
make[1]: *** [_module_/home/pi/Downloads/DPO_RT5572_LinuxSTA_2.6.1.3_20121022/os/linux] Error 2
make[1]: Leaving directory '/usr/src/linux-headers-4.14.98-v7+'
Makefile:388: recipe for target 'LINUX' failed
make: *** [LINUX] Error 2
  • 1
    Follow the steps in the tutorial, but use the correct interface name of your Wi-Fi card wlx9cefd5fcb786 instead of wlan0. If you still have some problems let us know. – oh.dae.su Mar 27 at 18:46
  • What OS are you using? – Milliways Mar 27 at 21:37
  • 1
    You've enabled predictable network interface names (or is that now the default?) - disable using raspi-config and go to Network Options=>Network Interface Names and select No - exit out of raspi-config, reboot, and done – Jaromanda X Mar 28 at 1:07
  • Thanks for the suggestions but still no luck. – Cryptanimator Mar 28 at 18:46
  • I have disabled predictable network interfaces and now I no longer see wlx9cefd5fcb786 in ifconfig or iwconfig and I tried changing etc/network/interfaces to use that instead of wlan0 but that completely disabled my internet connection, including wired ethernet auto lo iface lo inet loopback iface eth0 inet dhcp allow-hotplug wlx9cefd5fcb786 auto wlx9cefd5fcb786 iface wlx9cefd5fcb786 inet dhcp – Cryptanimator Mar 28 at 18:48
0

I ended up just reinstalling raspbian with the dongle plugged in, now it works great

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.