1

I have a Rapsberry Pi 3 A+ with an Adafruit Capacitive Touch HAT for Raspberry Pi (MPR121) and the idea is to plug it to the wet soil of a plant and it detects when I touch the plant (or a leaf) and plays an MP3 but it's not detecting the touch at all to have a result I have to touch the alligator clip connected to the plant directly.

The other thing that I tried is use a MakeyMakey and It works pretty well but you have to have a ground attach to the person.

I also tried a cheap version of the MPR121 Breakout (AliExpress) that have the same problems as the Adafruit HAT.

My code is in this repo if you want to check it out. I'm using Python3.6 with the Adafruit library for MPR121.

  • I think this is expected. Touch sensors work when you touch them directly or via a good conductor of electricity, which your plant obviously isn't. – Dmitry Grigoryev Mar 28 at 9:56
  • Hey @DmitryGrigoryev I don't know that much about it but with the MakeyMakey with the ground on my hand and the other cable connected to the plant works perfectly but with the touch sensor is not detecting anything, don't know if that could be the difference. – sabatesduran Mar 28 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.