I have MacBook Pro (Early 2011, so I'm sure it supports AirPlay) and XBMC running on raspbmc. I have enabled AirPlay in XBMC.

Streaming audio works like a charm (I can select XBMC as an audio output). However, my Mac OS X doesn't see XBMC screen as a video ouput. Menu bar icon doesn't appear and System Settings window says No Devices Detected:

enter image description here

I would like to share videos and pictures I watch on my MacBook with XBMC. Ideally, I would like to mirror my screen too.

I've seen on the internet people successfully made it with iPad, so I'm sure it's possible. Mac OS X, however, seems to cause problems.

How can I fix that?

  • Are both devices connected to the same router?
    – syb0rg
    Commented Sep 15, 2013 at 18:09
  • Can iTunes see XBMC? If yes, the mirroring option may require encrypted airplay which XMBC does not provide. Commented Sep 15, 2013 at 18:40
  • @syb0org Yes, both devices use the same router. Commented Sep 16, 2013 at 17:59
  • @ThorbjørnRavnAndersen iTunes does see XBMC but when I try to select it it shows error message An error occurred while connecting to the AirPlay device “XBMC (raspbmc)”. An unknown error occurred (-15000).. What's inttersting, when I select XBMC as an audio output (by clicking speaker icon in the menu bar while pressing the Option key) iTunes does see it and streams music to XBMC properly. Commented Sep 16, 2013 at 18:06
  • I would suggest opening a bug report with XBMC. This might be either a configuration issue, your router not being 100% compatible or a bug in the XBMC airplay implementation. Commented Sep 16, 2013 at 18:49

1 Answer 1


Airplay mirroring on Raspberry Pi with rPlay.

Please note that you will need a key to operate it in Mirror mode.

  • Got AirPlay mirroring successfully working, finally. Although it complains about ALSA and freezes sometimes, it starts and works, for some time at least. I'll continue solving the issues on rPlay forums. Thanks for suggesting rPlay! Commented Sep 17, 2013 at 17:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.