1

I am currently trying to setup my raspberry pi 3 to be a wireless access point. It is connected to an Enterprise WPA2 802.1x network via Ethernet. I have credentials for the network but it was easier to register the pi's mac address with my network admin and then just connect it to the network through wired Ethernet.

I want the RasPi to broadcast a wireless network to which I can connect wireless devices that are otherwise incompatible with Enterprise wifi.

So I followed the tutorial available here. In my case, the IP Address of my raspberry pi that I ssh into is 168.150.xxx.xxx, so I used 168.150.255.0/24 instead of 192.168.0.10/24 and similarly for the dhcp-range. (I'm unsure if this is the correct substitution to make, but neither the 192 nor the 168 worked).

However after rebooting I do not see the ssid I chose available to connect to. Any advice would be appreciated. (If there are logs located somewhere that will be of assistance, just let me know where to find them and I can provide them.)

  • How is the RasPi connected to the enterprise network? Wireless or wired? – Ingo Apr 2 at 21:59
  • Whoever wrote that tutorial needs to go take an undergraduate course in networks. It makes absolutely no sense to have both bridging and NATing on the same device. And that's not the only thing wrong with that tutorial. – JayEye Apr 3 at 2:48
  • Also: have you asked your network administrator for 802.1x credentials so your Pi can talk to your network? You also seem confused about how 802.1x authentication works. WPA2 is a WiFi security mechanism. You probably have confused it with the fact that 802.1x authentication in Linux is done with the wpa_supplicant service. – JayEye Apr 3 at 2:54
  • @Ingo The Raspberry Pi is connected to the network via Ethernet wired. – myraspberrypiscripts Apr 3 at 4:21
  • @JayEye Sorry if there is confusion between 802.1x and WPA2. I have credentials for the network but it was easier to register the pi's mac address with my network admin and then just connect it to the network through wired Ethernet. Any followup on what the issue is with the tutorial? The official raspberry pi site has a similar tutorial here that mirrors the same steps. – myraspberrypiscripts Apr 3 at 4:23
0

Your Raspberry Pi is already connected to the enterprise network with an ethernet cable. So it is not a big issue to setup an access point and connect it to the enterprise network. You have two options: routing or bridging. You have to decide what you want before going on.

Routing is more flexible and has a better performance than bridging. For example you can route part of your traffic to another subnet, maybe to a remote network at your home with openvpn. The access point and devices connected to it have its own subnet with own DHCP server, means their ip address range differ from that of the enterprise network.

Bridging is completely transparent to the enterprise network. That means, devices connected to the access point get part of that network with same ip address range and they can manage broadcasts. They can use a DHCP server on the enterprise network and any other things using broadcasts (e.g. seeing printer devices, using media sources, etc.). They behave as they were direct connected to the enterprise network.

How to configure an access point you can look at Setting up a Raspberry Pi as an access point - the easy way. For routing follow the instructions on section Setting up an access point and with eth0, with routing. You have to modify the file /etc/systemd/network/04-eth0.network to:

rpi ~$ sudo -Es # only if not already done
rpi ~# cat > /etc/systemd/network/04-eth0.network <<EOF
[Match]
Name=eth0
[Network]
DHCP=yes
IPForward=yes
EOF

Use the NAT solution by modifying the wpa_supplicant@wlan0.service as described. Maybe DNS=84.200.69.80 84.200.70.40 in /etc/systemd/network/08-wlan0.network must be modified to the DNS server used in your enterprise.

For bridging use section Setting up an access point with a bridge.

  • Thanks for the link. I started with a freshly updated Raspbian OS and followed the general setup and then the bridge guide, and upon rebooting my phone could see the network being broadcast. However, after attempting to connect it said "Failed to obtain IP Address." I then started again with a freshly updated Raspbian OS with the same process, but this time also followed the dnsmasq section too. After rebooting, this time my phone would get stuck in a loop of attempting to connect to the network, with no error message. Any further advice on how to proceed? – myraspberrypiscripts Apr 3 at 12:16
  • I'm thinking maybe this is due to restrictions set by the network admin, since I had to register the MAC Address of the raspberry pi for the wired Ethernet connection to even work. I would like to avoid using static IP Addresses but need to get this bridge working. Thanks. – myraspberrypiscripts Apr 3 at 12:20
  • @myraspberrypiscripts As already said: responsible for assigning ip addresses is a DHCP server running on the enterprise network. Is there one running? How does phones connecting to the access point of the enterprise get their ip address? Have you tried it with your phone? – Ingo Apr 3 at 12:27
  • 1
    Interesting (and final!) update: So I haven't worked on this in about 2 days but I plugged my pi back in today and spun it up (with the previous settings I was testing, which was exactly your configuration but with key_mgmt=WPA-EAP and frequency=2437. And RasPi network appeared and my devices could successfully connect to it! I then reverted the key_mgmt to the previous WPA-PSK and used my own password, and everything still continued to work. The only significant difference is that I am now using frequency 2437. – myraspberrypiscripts Apr 8 at 7:19
  • 1
    However I was using this frequency earlier with all other settings as is in the currently working RasPi and it was not working (same authentication issue). And I was definitely rebooting after every change in the wpa_supplicant-wlan0.conf file. So I'm honestly unsure what the issue was and what caused it to fix after the 2 days, but nonetheless it is now fully working with the "with NAT (recommended)" configuration from your tutorial. Thanks! – myraspberrypiscripts Apr 8 at 7:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.