2

Occasionally fswebcam -r 640x480 -S10 image.jpg would produce an Error selecting input 0 VIDIOC_S_INPUT: Device or resource busy error on my RPi 3.

I googled around a bit. I got some hits suggesting adding dwc_otg.fiq_fsm_mask=0x3 to the /boot/cmdline.txt file might fix that. It does, but it introduces new errors, 'Timed out waiting for frame!orVIDIOC_DQBUF: No such device`.

The new errors occur every time I run fswebcam so I removed dwc_otg.fiq_fsm_mask=0x3 and now I'm back to the original occasional error. But I'd like to be error free if possible.

Anyone out there understand this stuff well enough to suggest a fix?

  • What Operating System are you running? If it's Raspbian, which version of it? When was the last time you updated your Operating System? – David Apr 4 at 0:02
  • Have you tried any of the solutions listed here? If/when you do, could you please update your question so we know if any of these options worked? If they didn't, this will help us narrow the possibilities for an error. – David Apr 4 at 0:05
  • Running Raspbian GNU/Linux 8 (jessie) 4.9.35-v7+, last update/dist-upgrade early March. Generic 640x480 webcam plugged directly into a Pi3, no hub, 5v 3A power supply. Does anyone have a link to what dwc_otg.fiq_fsm_mask=0x3 actually is/does? – Kris Mclean Apr 4 at 3:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.