2

I have set the USB device on my Raspberry Pi to default. The file /lib/modprobe.d/aliases.conf:

options snd-pcsp index=-2
options snd-usb-audio index=0
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd_bcm2835 index=1

That worked out great, till I rebooted raspbian. After the reboot, the USB is not longer default.

But, The device is still displayed as default.

aplay -l:

**** Liste der Hardware-Geräte (PLAYBACK) ****
Karte 0: Device [USB Audio Device], Gerät 0: USB Audio [USB Audio]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0
Karte 1: ALSA [bcm2835 ALSA], Gerät 0: bcm2835 ALSA [bcm2835 ALSA]
  Sub-Geräte: 7/7
  Sub-Gerät #0: subdevice #0
  Sub-Gerät #1: subdevice #1
  Sub-Gerät #2: subdevice #2
  Sub-Gerät #3: subdevice #3
  Sub-Gerät #4: subdevice #4
  Sub-Gerät #5: subdevice #5
  Sub-Gerät #6: subdevice #6
Karte 1: ALSA [bcm2835 ALSA], Gerät 1: bcm2835 ALSA [bcm2835 IEC958/HDMI]
  Sub-Geräte: 1/1
  Sub-Gerät #0: subdevice #0

cat /proc/asound/cards:

cat /proc/asound/cards
 0 [Device         ]: USB-Audio - USB Audio Device
                      C-Media Electronics Inc. USB Audio Device at usb-3f980000.usb-1.4, full speed
 1 [ALSA           ]: bcm2835_alsa - bcm2835 ALSA
                      bcm2835 ALSA

In the raspbian gui in the top right corner at sounds, the USB device is also selected.

But when I play a Youtube video or play music with omxplayer, there is no Sound. When I start the vlc player, bcm2835 is selected. If i switch it to the usb device, then i can hear the sound with the vlc player only. When I open the pavumeter, the bcm2835 is also selected as the device. It used the USB device before.

Raspberry Pi 3 B

Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 9.8 (stretch)
Release:        9.8
Codename:       stretch

UPDATE: A workaround is blacklisting the bcm2835 device:

  • Add blacklist snd_bcm2835 in /etc/modprobe.d/raspi-blacklist.conf
  • PulseAudio remembers which card is the default. Try pavucontrol. – CL. Apr 5 at 13:39
  • pavucontrol shows me which audio device is used for the application and let me hanges this for the application. But how can i set this up for all applications global, that alle applications using the usb device instead of bcm2835? – raze92 Apr 5 at 13:46
  • @raze92, there are multiple answers here, some relatively old, some more recent. Have you tried the options described there? – David Apr 5 at 23:13
  • @David, thank you! Blacklisting the bcm2835 is a workaround, but not the optimal solution. But I will continue to work with it for now. – raze92 Apr 8 at 9:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.