1

I have a server in Raspberry Pi, hosted in a docker container. Currently I am accessing via localhost:8005or using my IP 192.168.0.101:8005.

I would like to mask the port number and access it without mentioning the port number. For example 192.168.0.103 or myserver.example.com

It is not necessary for me to access it from an external network. I just want to access within my own network to subscribe to MQTT.

I have read about reverse proxies and tried to implement them, but my port80 is blocked by ISP and I could not get my SSL signed. Is there any other way I can do?

Updates from comments:
I know MQTT uses port 1883. The server is actually has a platform that runs on port 8005. The platform can send data through MQTT on port 1883. To subscribe to MQTT, I must type 192.168.0.101:8005 -p 1883 which is not possible. So I want to mask 192.168.0.101:8005 with something else.

I can access my platform at 192.168.0.101:8005 But I have to type this in terminalmosquitto_sub -h 192.168.0.101:8005 -p 1883 \ -u FAMILY -P XX -t 'FAMILY/location/#' to subscribe via MQTT to obtain data.

The platform documentation suggests to use Caddy and reverse proxy the server to Web. My ISP has blocked port 80 and I can't get my SSL signed, so that option is not possible. So, I am looking for other alternatives where I can reverse proxy 192.168.0.101:8005 to local IP and use MQTT locally.

  • It seems each paragraph in your question is asking about an unrelated thing ... MQTT uses a default port 1883 - most clients that want to connect to MQTT will default to using port 1883 - don't see the problem – Jaromanda X Apr 6 at 9:13
  • Yes, I know MQTT uses port 1883. The server is actually has a platform that runs on port 8005. The platform can send data through MQTT on port 1883. To subscribe to MQTT, I must type 192.168.0.101:8005 -p 1883 which is not possible. So I want to mask 192.168.0.101:8005 with something else. – Irfanuddin Shafi Apr 6 at 9:31
  • I must type 192.168.0.101:8005 - where do you type such a thing? in a browser? why is 1883 not possible? – Jaromanda X Apr 6 at 9:35
  • I can access my platform at 192.168.0.101:8005 But I have to type this in terminal mosquitto_sub -h 192.168.0.101:8005 -p 1883 \ -u FAMILY -P XX -t 'FAMILY/location/#' to subscribe via MQTT to obtain data. – Irfanuddin Shafi Apr 6 at 9:43
  • Lol. Really. You specify a port in the host and as a port number. I think you may be doing it wrong – Jaromanda X Apr 6 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.