2

I'm using the Raspberry Pi 3 Model B V1.2, and the Sequent Microsystems 8 Relay Board 2.0. The manual tells you to install this software from github.

I installed this and was able to control the relays through the terminal, with the program working as it should. The terminal would tell me that I had 1 relay board attached, which was correct. However, after some time had passed I tried it again and now it did not detect any relay board. To test this I swapped out for another microSD card and tried again. This time, it told me that there were 8 relay boards attached, when there was only 1 (I tried using these anyway and there was no way to turn on the relay from here). I tried swapping out the pi itself and the relay board attachment, but nothing changed. It seems to be entirely dependent on the sd card, even after reboots, whether it displays 0 or 8 boards. I have no idea what to do, thanks.

  • Hi and welcome to Stack Exchange. Help me navigate the code: what command did you issue to find how many boards you have attached? – David Apr 6 at 16:54
  • After installing the "relay8" software (github.com/SequentMicrosystems/relay8-rpi), in the terminal I type "relay8 -list". Depending on the microSD card being used, it either tells me that there are 8 boards detected or 0 boards detected. – Luke Hamel Apr 6 at 17:06
  • Can you go to /proc/device-tree/hat and tell me what you see there before and after connecting your board? – David Apr 6 at 17:26
  • When I go to /proc/device-tree, I don't see a folder or file named hat on either card, before or after I connect the board. – Luke Hamel Apr 11 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.