0

My PC is running Windows 10. I'm working on establishing communications from my RPi to my PC via an ethernet cable. I've set up static IP addresses for both the PC and RPi on their respective ethernet adapters. I'm able to ping from my computer to the RPi and also connect to it using PuTTY, so there doesn't seem to be any problems there. I'm just not able to get the RPi to ping the PC's IP address. It won't do it. I'm not sure where my problem is originating, so I don't know how to resolve this problem. I scanned for IP addresses on my RPi and my computer's IP address appeared, which means that it at least knows that it exists, but it doesn't want to interact with it. How do I get my RPi talking to my PC over the Ethernet Cable? Any help would be appreciated greatly.

I followed the steps in this video: https://www.youtube.com/watch?v=5DCPDQnRXm8. But that didn't seem to work.

  • Possible duplicate of How to connect to the internet using an Ethernet cable – Tomas By Apr 9 at 23:57
  • what operating system does the PC run? perhaps there's firewalls preventing incoming connections on the PC – Jaromanda X Apr 10 at 1:10
  • use another PC to ping your PC .... what result do you get? – jsotola Apr 10 at 2:21
  • 1
    You can connect with Putty, so your network connection is working. What do you really want to do? The ping is just a test. Make sure your Windows firewall allows either everything on the local network, or the services you want to use. You can also allow ping in the firewall settings. This question really is about your Windows settings, not about the RPi. – RalfFriedl Apr 10 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.