1

I need to set up my Pi3 running on Raspbian Stretch so that on boot it will enable both interfaces, routing all WAN traffic through wlan0, because on eth0 there's just an old network printer waiting for prints.

Trying this with the GUI provided by Pixel Desktop (using the underlying wicd), the Pi boots, but waits for the user to turn wifi on - then making eth0 the default gateway for all traffic and refusing to let me delete that route. I tried removing wicd completely and only using the interfaces file, but then the networking will not start, complaining about wpa_supplicant exiting with 1.

I've read up on dhcpcd5, but trying to configure that gives me only eth0 working and wlan0 being softblocked by rfkill.

So how to correctly configure my interfaces?

My current network/interfaces-file:

source-directory /etc/network/interfaces.d
auto lo
iface lo inet loopback
allow-hotplug wlan0
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

dhcpcd.conf:

hostname
clientid
persistent
option rapid_commit
option domain_name_servers, domain_name, domain_search, host_name
option classless_static_routes
option ntp_servers
option interface_mtu
require dhcp_server_identifier
slaac private
interface eth0
static ip_address=192.168.1.1
metric 1
interface wlan0
metric 0
SSID myssid
static gateway=192.168.2.1
static routers=192.168.2.1
static_domain_search=mydomain
static ip_address=192.168.2.2
  • You are using an obsolete /etc/network/interfaces and if using Pixel an obsolete OS. Raspbian does not use wicd (although it is possible), your dhcpcd.conf does not make sense. See How to set up networking/WiFi and if after restoring settings you still have questions ask a question with detail of what you have configured. – Milliways Apr 10 at 10:47
  • I was referring to the Pixel Desktop. The OS is Stretch, as mentioned in the title. Sorry for not making that clear. – bstabens Apr 10 at 12:01
1

Got it at last. Solution:

  • reducing /etc/network/interfaces to mere minimum (maybe can also be deleted completely?)

    source-directory /etc/network/interfaces.d

    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf

  • installed wicd

  • removed AND purged rfkill
  • removed AND purged connman

Boom, instant success. eth0 now is statically configured, wlan0 gets IP via DHCP, routing is correct. Did not change dhcpcd.conf, by the way.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.