1

I just want to auto start Chromium on boot and I followed Method 1 over at this site. The same Method is used in the Top Answer here.

All in all it is about adding the command for starting the programm to

/etc/xdg/lxsession/LXDE-pi/autostart

with

sudo nano /etc/xdg/lxsession/LXDE-pi/autostart

the command, that worked for me is adding

@/usr/bin/chromium-browser --kiosk --disable-restore-session-state www.domain.com

I am only using the Pi over Remote Desktop and when I reboot and connect I can see Chromium in the Taskmanager, but not on the Desktop. I also know, that it works, because I used a website from which I get notified when I visit it, but when I connect to the Pi via Remote I can not see the Chromium Window. Is there any way to not opening a new session or something?

I am really new to Linux and help would be appreciated :)

Greetings

9
  • What is Method 1? Please give us the relevant information without pointing us to visit a link to understand your question.
    – Ingo
    Apr 13, 2019 at 20:42
  • @Ingo Sorry it was really dumb to just paste the link! I just edited my question, so that it is instantly visible what I have done and what was on the site.
    – KITRIK
    Apr 15, 2019 at 9:33
  • "Remote Desktop" means connecting from a MS Windows PC using rdp protocol? Or do you mean default VNC?
    – Ingo
    Apr 15, 2019 at 9:51
  • I did not know what VNC is, but I just found an answer that looks pretty promising I will try it soon, it uses VNC. askubuntu.com/a/240013/878452 And yes, my aim is to connect from a Windows PC to a Pi in my basement.
    – KITRIK
    Apr 15, 2019 at 9:53
  • @Ingo I tried to follow the answer over at askubuntu.com/a/240013/878452 which is to use VNC with VINO to connect to the local session, but it was impossible for me to access 'vino-preferences' so I do not know any further. When I tried to connect without editing in 'vino-preferences' I got a 'VNC error - problem connecting'. Any advice?
    – KITRIK
    Apr 15, 2019 at 10:54

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.