0

I feel uncomfortable sending out emails from my Pi via gmail but can't see how to change /etc/ssmtp/ssmtp.conf to use hotmail instead.

Anyone done this please and if so could I see the /etc/ssmtp/ssmt.conf layout you used. I installed https://trustfoundry.net/honeypi-easy-honeypot-raspberry-pi/

the ssmtp.conf file currently looks like the one below

# The user that gets all the mails (UID < 1000, usually the admin)
[email protected]

# The mail server (where the mail is sent to), both port 465 or 587 should be acceptable
# See also https://support.google.com/mail/answer/78799
mailhub=smtp.gmail.com:587

# The address where the mail appears to come from for user authentication.
rewriteDomain=gmail.com

# The full hostname.  Must be correctly formed, fully qualified domain   name or GMail will reject connection.
hostname=yourlocalhost.yourlocaldomain.tld

# Use SSL/TLS before starting negotiation
UseTLS=Yes
UseSTARTTLS=Yes

# Username/Password
AuthUser=username
AuthPass=password
AuthMethod=LOGIN

# Email 'From header's can override the default domain?
FromLineOverride=yes
4
  • 1
    First, what package did you install to get /etc/ssmtp - it's not part of the base install of raspbian, so you must've installed something to get that - second, what is the current content of ssmpt.conf? Apr 14, 2019 at 0:51
  • hi @JaromandaX thank you for taking an interest. I have updated the question to provide clarification.
    – theakson
    Apr 14, 2019 at 23:03
  • Hello. Obvious question but have you tried replacing the "gmail" parts in the configuration with the Hotmail settings? If you did, why not show us that instead (without your password!) and include the errors you get. Apr 15, 2019 at 9:33
  • @RogerJones hello back. Jaromanda asked for what existed and that's what I posted. I WAS hoping that someone else had trodden this path but seems I am the only paranoid one :-) You make fair points and the answers are YES I tried the hotmail settings ( thanks for the link I did know them before but very helpful) and NO I didn't record the errors. I will do so this weekend.
    – theakson
    Apr 16, 2019 at 11:40

1 Answer 1

0

ssmtp has been deprecated in Debian Buster.

I used this configuration which worked. I needed to change ssmtp.conf and revaliases

ssmtp.conf

[email protected]

mailhub=smtp.office365.com:587

rewriteDomain=hotmail.com

[email protected]

AuthPass=your_password

UseSTARTTLS=YES

hostname=raspberrypi.localdomain

FromLineOverride=YES

revaliases

root:[email protected]

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.