0

I have installed the latest version of Raspbian and uname -a gives the following:

Linux mypi 3.6.11+ #541 PREEMPT Sat Sep 7 19:46:21 BST 2013 armv6l GNU/Linux

And I have used these instruction by secretagent.

But when I try modprobe usbip-host the Pi hangs and must be rebooted.

Any ideas, anyone?

5
  • 1
    Did you look in the logs?
    – goldilocks
    Sep 18, 2013 at 11:07
  • Yes, not a word!
    – Gohper
    Sep 18, 2013 at 11:55
  • I will try to run the modprobe directly at the shell. It may give me some more info. Currently I am accessing the Pi vi ssh.
    – Gohper
    Sep 19, 2013 at 6:32
  • Run the command at the console. There are some info, but I have not had the time to investigate futher.
    – Gohper
    Sep 27, 2013 at 6:40
  • Have you solved this issue yet? If so, could you please create a self-answer and mark it as such. We are trying to get the Q:A ratio up and that would help us a ton. Thanks! Mar 3, 2014 at 17:37

2 Answers 2

1

It is important to make sure that the version of the kernel you are using and the modules you are compiling are matching. There are no safety nets in place; it will usually just crash if they don't line up.

It might be a good precaution to use the exact same kernel source used to compile the module to compile a new kernel image and replace the existing, though the wait is about 10 hours for build to finish on the rPI and takes >3GB. Offsite build might be the better way to go but I've never tried it.

0

I'd suspect there's an unfortunate interaction occurring between the less than stellar USB stack of the Pi and the software. You may need to wait a few kernel versions for the software to get better and then try again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.