1

I have a problem with NOOBS. I have tried to download Raspbian onto the SD card directly from NOOBS, and as soon as the download starts, I get the regular message "Please wait while the software is installed on your SD card - this may take a few minutes." Underneath it, it says Raspbian Full: Creating Filesystem (FAT). It has been stuck on this for hours and the Pi is not responsive and I've tried restarting the process several and reformatting the SD card, which works fine if you directly download Raspbian onto it. Does anyone have any idea of how to get this to work? I would try to get the picture of it up, but the one I took is above the site limit of 2MB. I'm trfying to install this onto a Raspberry Pi Zero, with an 8gb SD card, which should be enough for Raspbian. Hope you can help.

  • 1
    NOOBS does not "download Raspbian" it is included in NOOBS, so your NOOBS download is probably corrupted. NOOBS is not used by the experienced people on this site. 8GB is barely adequate for Raspbian; NOOBS wastes over 1GB of this leaving little space for anything else. – Milliways Apr 16 at 12:04
1

Finally figured it out, the 8GB SD card may have been corrupt, or maybe the fact that it only had 7.4GB that the system could actually use may have stopped it creating the Filesystem properly. Now I have a 32GB in there and PINN works fine - I assume NOOBS does too

0

Don't bother with Noobs:

  1. Download 'Raspbian Stretch with Desktop' https://www.raspberrypi.org/downloads/raspbian/
  2. Flash image to sd card using Etcher https://www.balena.io/etcher/ (no need to unzip image)
  3. Place sd card in Pi and turn on
  • I know that Raspbian works fine when I download it directly, any idea on how to get NOOBS working, I just want to test it out, and see if I can make it work and it may help when I get a bigger SD card so I can have both Raspbian and LibreELEC downloaded – Nainman Apr 16 at 10:09
  • You should update your question with that information. Maybe try PINN github.com/procount/pinn – CoderMike Apr 16 at 10:21
  • I have the same problem still, even with PINN. It is stuck on Creating File system(FAT). Nevermind, I fixed it using the solution in the answer I made – Nainman Apr 16 at 18:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.