I was working on getting my new Raspberry Pi HAT that I have received and tried the simple example just to see if it is working fine. I have not been able to send a text message to my mobile phone.

I followed the instruction step by step on SixFab Github for their RPI Cellur HAT

When I run sendSMS.py which contains the code below with my phone number I get BG96 is enabled and B96 is started

Then I get a bunch of ATE1 that continuously echo until I cancel out the process.

from cellulariot import cellulariot
import time

#node = cellulariot.CellularIoT() # for Sixfab CellularIoT HAT
node = cellulariot.CellularIoTApp() # for Sixfab CellularIoT App. Shield



node.sendSMS("xxxxxxxxxxxxx","hello world!")

Does anyone know why it just continuously throws ATE1 to the command. I am using Hologram_IO as my carrier.


This means the "ATE1" command send to the BG96 did not succeed and is still trying. Knowing the library, the command that is printed actually means that the command is being send to the BG96. This loop in this function that is called in the sendATComm:

def sendATCommOnce(self, command):
    if (ser.isOpen() == False):
    self.compose = ""
    self.compose = str(command) + "\r"

This will continue until the desired response is accepted from the BG96, the desired response is the second argument when you call the function:


I dont know why your doesn't work though, the only thing I can suggest is to change it to just "OK" without "\r\n".


Go to /etc/ppp/peers/provider and set the communication rate to 9600

  • Could you explain how to do it and why it should help? I would expect the asker getting no communication at all if a wrong baudrate was set. – Dmitry Grigoryev Jun 13 '19 at 6:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.