1

I have been running IncrediblePBX on an older version of Raspberry PI. I have made an image and copied to new micro SD card, but cannot get it to boot on newer versions of Raspberry Pi.

I have followed the instructions from https://thepihut.com/blogs/raspberry-pi-tutorials/16982376-updating-raspian-on-your-microsd-for-the-raspberry-pi-2 to upgrade the OS, but still will not boot on newer Pi.

I have also tried the recommendations from Raspberry Pi 2 BCM2836 working but new Raspberry Pi 2 BCM2837 stuck on Rainbow Screen, but when I run apt-get install raspberrypi-bootloader I receive "Module not found".

I ran the cmd cat /proc/cpuinfo on the working Pi and discovered I have Hardware-BCM2708 Revision 000e.

I'd appreciate any suggestions on how to get the microSD card to boot on a newer Pi. So far I've tried to boot it on a Raspberry Pi 2 Model B and a Raspberry Pi 1 Model B+, neither will boot.

  • I have made an image and copied to new micro SD card does this new card work on old Pi? How did you create the image for the new SD card? – Jaromanda X Apr 17 at 15:01
  • I used Win32DiscImager to copy the SD card of the original system, then I used Balena Etcher to write to the new Micro SD card. I also tested by inserting the micro into an SD adapter and running on original Pi – britchey Apr 17 at 17:08
  • does the windows readable partition on the SD have kernel7.img file? – Jaromanda X Apr 17 at 22:40
  • There is a kernel.img, but no kernel7.img. Would this make a difference? – britchey Apr 18 at 12:12
  • Must be as old image – Jaromanda X Apr 18 at 12:14
1

"In normal circumstances there is NEVER a need to run rpi-update as it always gets you to the leading edge firmware and kernel and because that may be a testing version it could leave your RPi unbootable". https://www.raspberrypi.org/forums/viewtopic.php?p=916911#p916911 Even the rpi-update documentation now warns "Even on Raspbian you should only use this with a good reason. This gets you the latest bleeding edge kernel/firmware."

sudo apt-get update; sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel will put it back to the latest supported kernel/bootcode.

I ran rpi-update. This updated the Kernel. I can now boot the Micro SD on newer Raspberry Pi models.

  • Thanks for this information. I did try sudo apt-get update; but I wasn't aware of sudo apt-get install --reinstall raspberrypi-bootloader raspberrypi-kernel – britchey Apr 20 at 18:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.