I've tried to include as much information as possible, but if it isn't relevant I will remove it.

I purchased a Raspberry Pi 4 months ago, and I've been using it to run some CRON jobs. I have a Logitech keyboard and mouse, which I used with the Pi during the initial week, but haven't connected them since, because running it headless was easier. Last week, I decided to start using the Pi as a media server at home and connected it to a Hard Disk (NTFS). Now because my TVs won't recognise some video file formats over DLNA, I installed Kodi. I don't know if it's worth mentioning, but I also installed OpenHab during the same time.
Now, the Kodi Desktop Environment is not rendered in VNC and so I had to enable 'Experimental Direct Capture Mode'. This caused my VNC CLient to say 'Cannot currently show the desktop'. To rectify this, I tried to disable the option on the Pi with my keyboard and mouse, and that brings me to the issue.
The keyboard and mouse receive power (lights work). The USB ports themselves work fine, since I'm able to connect the hard disk to any of the ports and use it without an issue. The keyboard also works without any issues on the terminal during boot. But once the Desktop GUI loads, neither the keyboard nor the mouse work. I've tried removing the hard disk, thinking it was a power issue, but that doesn't seem to be the problem. What can I do?

EDIT: This is not a duplicate of this question, since I don't get these errors:

libkmod: ERROR ../libkmod/libkmod.c 554: kmod_search_moddep: could not open moddep file '/lib/modules/3.18.5-v7+/modules.dep.bin'
Error opening '/dev/input/event*': No such file or directory
  • Ok.. I disabled kodi at boot, and everything went back to normal after a few reboots. So problem solved. I don't know what caused it though, so the question is still open. – SvbZ3r0 Apr 27 '19 at 12:51


have been using CRON jobs

have Logitech keyboard and mouse

used with the Pi initially, haven't connected them since, becaue running it headless

now to start using Pi as a media server, and connected it to NTFS, Kodi, OpenHab

Kodi in "Experimental Direct Capture Mode", causing my VNC CLient to say 'Cannot currently show the desktop'

I tried to disable the option on the Pi with my keyboard and mouse <<<<

USB ports work fine, hard disk to [USB] ports without an issue

Keyboard also works without any issues on the terminal during boot.

Once Dsktop GUI loads, neither the keyboard nor the mouse work.


I assume you are using physical wires to connect your keyboard and mouse to Rpi. But if you are using wireless USB dongles, make sure you don't have Windows/Mac nearby, also with wireless stuff confusing Rpi. And you can switch off all WinPC/Mac, and try to plug your keyboard mouse dongles (or one for two) to your PC/Mac to make sure the keyboard and mouse are no run out of batteries, or not adequately charged.

So now you don't VNC/SSH. Perhaps you should check the Desktop Rpi Config that VNC/SSH are disabled.

rpi setup

|improve this answer|||||
  • The keyboard and mouse are wired. SSH and VNC are enabled and although I did say I had a problem with VNC, that is not my question. I don't have an issue at all with SSH; it works fine. My mouse and keyboard don't work in the desktop GUI. I want to know how to rectify that. – SvbZ3r0 Apr 22 '19 at 7:09
  • Do you mean I should disable SSH and VNC for the keyboard and mouse to work? – SvbZ3r0 Apr 22 '19 at 7:13
  • Ah, I thought you are not using SSH/VNC for a while anyway, you can disable them, at least to check out if if it helps. – tlfong01 Apr 22 '19 at 7:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.