1

I have similar issue as mentioned in below link Raspberry Pi 3 B - no ping from Windows Computer on LAN

The pi model is 3B+ and have installed latest NOOBS from the below https://downloads.raspberrypi.org/NOOBS_latest

Pi has internet connection and shows the proper LAN ip address ( 192.168.0.106 ) , PC is also on the same network (192.168.0.104 ), but neither of them ping with each other. SSH through Putty does not work. Am at my wit's end trying to solve this issue. Any suggestions will be of immense help

regards, Saagar

2
  • Can any of them ping the default gateway?
    – MatsK
    Commented Apr 22, 2019 at 17:27
  • 1
    NOOBS is not an operating system. It is an installer for Raspbian and more. What operating system do you install with NOOBS? Do you use Raspbian Stretch? Please execute these commands, edit your question and paste its output to it: ip addr and ip route. Please address me with @Ingo, otherwise I won't see your reply.
    – Ingo
    Commented Apr 22, 2019 at 18:37

1 Answer 1

1
  1. Is the SSH service enabled on your Pi? You can check this by running sudo systemctl status ssh. If it isn't, then do the following. (source)

    • Enter sudo raspi-config in a terminal window

    • Select Interfacing Options

    • Navigate to and select SSH

    • Choose Yes

    • Select Ok

    • Choose Finish

  2. If it is indeed running, but you still are unable to connect to it, then, as mentioned in the link you provided, does your SSH work on WiFi instead of a wired connection?

    • If it does, then did you previously assign your eth0 connection a static IP instead of your wlan0? If you did, then follow this tutorial as to how to reverse this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.