8

I am able to ssh into my new RPi. One of the things I like to do to my infrastructure devices is to go ahead and convert their DHCP assignment to a reservation. My router is a CradlePoint

Firmware Version : 2.0.0, 2012/04/16
WiMAX Version : 4.1.645

I added a reservation, revoked it on the router and did a sudo dhclient -r then sudo dhclient and it picked up yet another IP address instead of the one I had reserved - a full reboot seems to have little effect.

I don't have any other trouble with this router and other devices.

3
  • Why not just configure a static address on the RPi?
    – Kibbee
    Commented Jul 8, 2012 at 2:52
  • 7
    @Kibbee Because I can manage the DHCP in one place separate from whatever images I may fool around with on the device, and I also have a number of routers and a static IP would lock it to that subnet until it's edited.
    – Cade Roux
    Commented Jul 8, 2012 at 3:00
  • Install avahi-daemon on the Pi and Bonjour support on your regular computer - then connect to "raspberrypi.local." Commented Aug 7, 2012 at 17:20

2 Answers 2

2

I also had this problem and I found it was because the MAC address of the Pi was changing whenever it rebooted. Although difficult to pin down a solution, my recommendation would be to upgrade the Pi firmware.

Here is an answer I wrote on how to upgrade the firmware:

How do I update software and firmware?

A lot of issues such as this tend to be firmware related.

4
  • 4
    That didn't seem to help - my MAC address appears to be the same on each reboot. I'm going to try putting it on another router and setting up the reservation before it has ever seen that network.
    – Cade Roux
    Commented Jul 8, 2012 at 13:51
  • 1
    @CadeRoux Sounds to me like a router issue...?
    – Jivings
    Commented Jul 8, 2012 at 15:40
  • I reserved an address before plugging it into another router (a Netgear WPN864) and it picked up that address. Then I moved it back to the original router and it picked up the reservation on that one! I moved it back and forth a few times and it appears to be working. It somehow developed an affinity to not pick up a reservation from the original router, but it's somehow gotten over it. Mystery no longer reproducible...
    – Cade Roux
    Commented Jul 8, 2012 at 17:13
  • @CadeRoux Nice work.
    – Jivings
    Commented Jul 8, 2012 at 17:15
0

When I ran into a similar problem today (reserved address on the router, but the client would not pick it up) I temporarily changed the DHCP lease time on my router to 30 seconds, waited 30 seconds, then ran the dhclient commands (see original post)

After confirming the client now had the desired IP, I set the router's DHCP lease time back to its previous value (86400 seconds in my case).

1
  • You should also be able to shut down dhclient, clear the leases out of /var/lib/dhcp, and start it again. It will ask for a new lease and the router will give it the reserved IP.
    – goldilocks
    Commented Apr 5, 2022 at 13:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.