0

I have a Raspberry Pi B+ (2014) that was working great until I formatted an external hard drive, restarted the Pi, and ran into this issue with fstab.

I tried putting the SD card in both an old Nook and a Samsung Galaxy Tablet in order to edit the fstab file, but only the "boot" partition mounted and I couldn't get into rootfs. While it was in there, it looks like the nook dumped a bunch of android and other files on the SD card. I'm not sure if the Galaxy Tab did the same.

I have since gotten a proper SD-USB adapter and plugged the RPi directly into my laptop, edited out the last line of the fstab file with root permissions, and put it back in my Pi. However, now I don't even get to the error screen about fstab, and instead the Pi doesn't boot up at all. As soon as I plug in the power the red and yellow LEDs light up but nothing happens (with or without a monitor plugged in, with or without the originally-formatted HD plugged in) and the lights don't even flash for a second at bootup. I've tried deleting all of the android files, and even putting back the last line in fstab at least to get the error screen, but still nothing happens.

I've tested it and the Pi still works with a fresh SD card, but I spent a lot of work configuring the previous installation and am not in the mood to give up and restart the process just because of a bug in Raspbian.

Any ideas what could have happened to this SD card that's not allowing it to boot up anymore?

  • 1
    have you tried to copy the files from the working boot to the non-working boot – Jaromanda X Apr 25 at 6:46
  • I doubt the SD card is damaged. However you have scribbled over the SD card files presumably changing ones needed by the Pi to boot. I suggest you try the suggestion of @JaromandaX – joan Apr 25 at 8:26
  • I'll go ahead and try that if I don't get any other answers today, thanks. I didn't want to mess with the non-working boot at all at this stage for fear of messing something up. I'm also not sure what the software version was but I guess I'll need to try to figure that out and make a new SD card loaded with that older version. – chkiss Apr 25 at 13:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.