1

I was upgrading my ADC Hat mounted(no other sensors), Raspberry Pi 3 B (Stretch installed) using;

sudo apt-get update
sudo apt-get upgrade

During the middle of the upgrade, there was a message with some information(which I couldn't remember exactly) and as per the option provided I pressed 'q' to quit. Then the upgrade continued again quite a long time.

I interrupted it in the middle and shut down the Pi. Then removed the ADC and restarted the Pi.

Unfortunately, now my Pi is not a working.No response to keyboard, mouse, taskbar not visible but the desktop(image) and the icons/folders are visible. :(.I have restarted the Pi several time by powering on/off, still the same no response.

I have captured the messages during the boot and it is as below. enter image description here

Any help or guidance to fix this issue "Failed to start load kernel modules", please? Though I tried to open the command line to try solutions I'm unable to open the cmd by CTRL+ALT+F1 since no keyboard response.

Thank you.

  • I think your only option is to re-flash your SD Card. – CoderMike Apr 26 at 7:38
  • Oo then I will lose all the documents inside that isn't it? I'm sorry is there any option to save them? – Sachz Apr 26 at 7:44
  • Flash a new sd card and then you may be able to copy files from the old card with a usb sd card adapter. – CoderMike Apr 26 at 8:13
  • Thank you very much for the suggestion. I will try this and re-flash the SD card. – Sachz Apr 26 at 9:33
1

The good news is that the all the data in your home directory is almost certainly still there.

DO NOT reformat the SD Card - it will be readable in any Linux OS (including Raspbian).

Take this as a lesson to backup your data before updating.

  • Yes, data in the home directory is still available and I have copied them using USB -SD card adapter. Thank you very much, for your guidance. Yes... I will make sure to "backup data". – Sachz Apr 27 at 9:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.