1

I have setup my RPI 3 B+ model to act as an NTP server but I'm not able to sync my window machine to it.

The NTP server uses PPS from GPS devices (Adafruit ultimate GPS hat) attached to external antenna

The windows machine IP (acting as NTP client) 192.168.43.15 My RPI3 IP address (Has NTP server) 192.168.43.147

When I try to sync the windows machine to the RPI NTP server here is what I get:

https://imgur.com/LnvEVwi

The NTPQ -p result from the RPI is

https://imgur.com/a/ij5wlEt

When I ping the RPI IP from windows this is what I get https://imgur.com/a/vpwkVLp

Here is my ntp.conf files setting

# /etc/ntp.conf, configuration for ntpd; see ntp.conf(5) for help

driftfile /var/lib/ntp/ntp.drift

# Enable this if you want statistics to be logged.
#statsdir /var/log/ntpstats/

statistics loopstats peerstats clockstats
filegen loopstats file loopstats type day enable
filegen peerstats file peerstats type day enable
filegen clockstats file clockstats type day enable


# You do need to talk to an NTP server or two (or three).
#server ntp.your-provider.example

server 127.127.20.0 iburst true prefer 
fudge 127.127.20.0 flag1 1 refid GPSD
server 127.127.22.0 iburst true prefer 
fudge 127.127.22.0 flag1 1 refid KPPS

# pool.ntp.org maps to about 1000 low-stratum NTP servers.  Your server will
# pick a different set every time it starts up.  Please consider joining the
# pool: <http://www.pool.ntp.org/join.html>
#pool 0.debian.pool.ntp.org iburst
#pool 1.debian.pool.ntp.org iburst
#pool 2.debian.pool.ntp.org iburst
#pool 3.debian.pool.ntp.org iburst

restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap
logfile /var/log/ntp.log

# Access control configuration; see /usr/share/doc/ntp-doc/html/accopt.html for
# details.  The web page <http://support.ntp.org/bin/view/Support/AccessRestrictions>
# might also be helpful.
#
# Note that "restrict" applies to both servers and clients, so a configuration
# that might be intended to block requests from certain clients could also end
# up blocking replies from your own upstream servers.

# By default, exchange time with everybody, but don't allow configuration.
#restrict -4 default kod notrap nomodify nopeer noquery
restrict -6 default kod notrap nomodify nopeer noquery

# Local users may interrogate the ntp server more closely.
restrict 127.0.0.1
restrict ::1

# Clients from this (example!) subnet have unlimited access, but only if
# cryptographically authenticated.

# If you want to provide time to your local subnet, change the next line.
# (Again, the address is an example only.)
broadcast 192.168.43.147
#broadcast 224.0.1.1

# If you want to listen to time broadcasts on your local subnet, de-comment the
# next lines.  Please do this only if you trust everybody on the network!
#disable auth
#broadcastclient

  • 2
    Please include the text of your tests, rather than linking to screenshots. It makes the question much easier to read if you do so. – Heath Raftery Apr 26 at 13:22
1

You have not provided access to your local subnet. Change this line:

restrict 192.168.1.0 mask 255.255.255.0 nomodify notrap

to this:

restrict 192.168.43.0 mask 255.255.255.0 nomodify notrap

so your Windows computer has access. Then remove or comment out this line:

broadcast 192.168.43.147

because you probably don't want to broadcast NTP, and certainly not to that address.

Then, don't use w32tm as a ping tool - it's definitely not a ping tool and the /stripchart option doesn't test NTP servers. Instead, monitor /var/log/ntp.log and try netcat instead. For example, this uses netcat to check if the NTP server is listening:

nc -zuv 192.168.43.147 123
  • Thank you Heath for your helpful answer. I tried your changes and it only worked when I added additional internet pool server. But it does not work when I only have my GPS and PPS as the only server in the ntp.conf – MikeAlbert Apr 26 at 19:38
  • Great, sounds like the NTP server is working. Perhaps ask another question about getting it connected to gpsd. In that question, explain what 127.127.20.0 and 127.127.22.0 refer to. – Heath Raftery Apr 26 at 21:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.