I followed the guides for installing python 3.7 and the installation went without issue, and code I write can run just fine. Installing other modules like numpy and matplotlib doesn't result in any errors, but when I try scipy, I can't get it to install no matter what I do. I'm using pip by typing the command python3.7 -m pip install --user scipy, which I used for the other modules. This is what it ends with when I try the above command:

This is just the end of the terminal...

It seems that it most of the errors are repeated. There's also a lot more errors above, but I can't even scroll up to the original command I typed in there's that many.

I ran sudo apt-get update && sudo apt-get upgrade beforehand too, so nothings out of date. I did rerun the dependencies commands too, but that didn't seem to help. I suppose it might be because its not installing to python 3.7, but I'm sorta new so I can't tell myself.

I did install scipy to python 3.5.3 previously too, and that worked fine once I got it to stop installing to python 2.7.



Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Browse other questions tagged or ask your own question.