0

I am using a flat ethernet cable, connecting my Laptop output to RPi ethernet. I have left the /etc unmodified (to its original state) I have enabled my PC windows network for external ethernet device.

I am in Detroit.

I am unable to connect to network. Here are my experiments and the results...

root@raspberrypi:~# ifconfig
eth0 Link encap:Ethernet Hiaddr b8:27:ab:d5:24:1b
        inet addr:192.168.1.7 Bcats:192.168.1.255 Mask:255.255.255.0
        UP........(7.2 KiB)
lo     Link encap:local Loopback
        inet addr:127.0.0.1 Mask:255.0.0.0
        UP....(4.5 KiB)

root@raspberrypi:~# netstat nr
Kernel IP routing table
Destination-Gateway-Genmask-Flags-MSS-Window-irtt-Iface
0.0.0.0-192.168.1.1-0.0.0.0-UG-0-0-0-eth0  
192.168.1.0-0.0.0.0-255.255.255.0-U-0-0-0-eth0

Also tried to ping the router but get "Host Unreachable" reply.

  • 1
    Have you enabled "internet connection sharing" on your Windows laptop? – Dougie Apr 28 '19 at 15:07
  • Do you can ping 192.168.1.1 from the RasPi? – Ingo Apr 28 '19 at 19:37
  • What router do yo try to ping? Where is it? What ip address does it have? Please address me with @Ingo, otherwise I won't see your reply. – Ingo Apr 28 '19 at 19:48
0

First make sure your laptop has network configuration in the same range as of Rpi, ie. both the devices uses same IP ranges with same netmask. Then make sure windows firewall is disabled because win. firewall don't let ICMP packet to exchange by default. If these steps were all ok you may have erroneous cabling.

| improve this answer | |
  • Many Thanks dear, I could resolve the issue, the problem was my Laptop's ethernet port was not properly shared with RPi for the wireless connected WiFi – user2064616 Apr 30 '19 at 14:43
  • This Question post by user2064616 may be treated as CLOSED please, Thanks to all those who tried to help me... – user2064616 Apr 30 '19 at 14:49
  • @user2064616 It cannot be closed by another than yourself. Only accepting an answer will finish the question. So please create a short answer and accept it after two days. Otherwise it will pop up again and again and bother us all the years. – Ingo May 30 at 1:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.