1

Need help setting up comm between an Integ Jnior and our primary domain. Here's what I've done so far. I've taken RPi 3 B+ and set it up as a DHCP server broadcasting 10.1.1.1. Wlan0 on the Pi has pulled a lease of 192.168.1.216 from our primary internal network.

Everything works great with a laptop connected to eth0. I'm able to get out through and back with the Pi. The issue I'm having... and I'm certain it's a simple one, is when I plug the Integ Jnior into eth0, it pulls an address correctly and I can interface through the Pi on (current lease 10.1.1.119). When I try to connect to 10.1.1.119 from our primary network (192.168.1.1)... bupkis.

On the Integ Jnior it's set to DHCP and pulls an address from the RPi. The Gateway is set to 10.1.1.1, the primary dns is set to 10.1.1.1 and 2nd is 0.0.0.0 . I have the local domain set to mycompany.com

What I need to accomplish now is accessing the Jnior device through our primary network. My gut is telling me it's in the iptable or a dns issue. Thoughts or solutions are greatly appreciated.

  • You wrote: "Wlan0 on the Pi has pulled a lease of 192.168.1.216 from our primary internal network". That implies that there is a DHCP server running on the primary internal network: Can you confirm this? Where is the bridge? What is bridged? What iptable issue? – Ingo Apr 30 at 18:00
  • Yes, the Wlan0 on the Pi has pulled this address from our primary network which is set to DHCP. – j_pap4949 Apr 30 at 18:53
  • Where is the bridge? What is bridged? What iptable issue? – Ingo Apr 30 at 18:55
  • Got cut off, apologies. Yes, the Wlan0 on the Pi has pulled this address from our primary network which is set to DHCP for a good portion of the 192.168.1.1 range. In regards to the bridge, I've configured the pi to share the wlan0 with eth0 as a pass through if you will. Works with a normal laptop but not the device I have plugged to eth0 on the pi. As for the iptable, I'm spitballing on why I cannot connect to 10.1.1.119 through the pi from my computer that's on the 192.168.1.1 net. – j_pap4949 Apr 30 at 18:59
0

What you are trying to do cannot work. There is a big issue you should fix immediately. You have a DHCP server running on your primary internal network. In addition to this DHCP server you setup another one on the RasPi. Now you have two DHCP server running on the same subnet.

This is out of specification and violates your primary internal network. If a device requests an ip address then both DHCP server will respond and each will offer an ip address without knowing what the other DHCP server has done so far. Is it possible that devices get the same ip address from different DHCP server and this will break their communication. You should shut down the DHCP server on the RasPi as soon as possible.

As long as there are two DHCP server running you cannot say anything about the behavior of devices.

You are also talking about a bridge. You cannot bridge wlan0 as client connection with eth0. This is not supported by the on-board wifi device of the RasPi. For further information about this issue look at Raspberry Pi WiFi to Ethernet Bridge for a server?.

As for using iptables: this is a firewall and it is used to restrict connections. If you have problems with connections I would first avoid using it in addition and would make it completely transparent. When your connections are working then you can define your firewall rules step by step.

0

Can I ask why you need a bridge in order to put your JNIOR on the network? You can disable DHCP on the JNIOR and assign whatever addressing that you need. You can reach the command line console through the lower RS-232 port (115.2 KBaud, 8 data, 1 stop, no parity). Use HELP to view the options for the IPCONFIG command. There are slight differences between the Series 3 (310, 312, or 314) and the Series 4 (410, 412, or 414). A USB-to-Serial adapter works great for that.

You can also download the Support Tool from the INTEG site (integpg.com). It is freely available. Run this on a Windows machine on the same subnet as the JNIOR. The JNIOR when connected to that subnet should show up under the Beacon tab. Right-click and you can setup the IP configuration for the JNIOR.

  • Hi Bruce, thanks for reaching out to me. Racking my brain on this one for sure. The reason is our machinery, ~100 machines, do not have network cable run to them. Huge expense when you're cabling hundreds of thousands of sq/ft. We just installed expansive wifi networks wrapped around all of our facilities. I want to connect the pi 3b+ to eth0 and and pull the data through that way. I have the Support Tool from Integ on my laptop and I'm using it. I'm heading a different direction as far as the pi goes. Going to try the pi as a router. Any thoughts are appreciated. – j_pap4949 May 7 at 20:09
  • Just realized you're the face of Integ on YT. – j_pap4949 May 7 at 20:10
  • You can create a small local network segment with an inexpensive WiFI access point. I can check with Kevin (or you can) for device recommendations. We have customers doing that and also using cellular modems. In the long run it'll be less expensive and likely easier than the Pi. Although probably not as educational. We've not built a WiFi version of the JNIOR (yet). Partly because there are other solutions. Partly because that changes the class of the device and pushes up the cost. There is always a first for everything. – Bruce Cloutier May 8 at 22:53
  • BTW, you can do a lot with the JNIOR. Our documentation is lacking. But, generally it is because no one reads it. You can find some stuff on jnior.com. But feel free to call us or email us at INTEG. The Raspberry Pi is a cool tool but there are things that you might think to use the Pi to do that can be easily handled on the JNIOR. – Bruce Cloutier May 8 at 23:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.