0

I have RPI3B + with Raspian Stretch on which I run the QT application. When I create my service to launch the application after starting the rpi i have problems.. The application starts and then the desktop is loaded and pushes it into the desktop background. When I am moving the mouse on the screen in the background my application starts to break through. The application basically works but it works with a very long delay and keeps jamming. When I run the application normally through the console everything works fine and I do not have any lags.

How else can I run the application? I suspect that the application is started too fast and hence the problem .. :|

EDIT
The application is written in QT 5.12.3, it is a car counter, it uses LCD 12.3 and a CAN-BUS converter. As I wrote, the application starts fairly quickly, but it gets stuck when it is started using the service (init/systemd service). the service starts the file start.sh:

ip link set can0 type can bitrate 100000
ifconfig can0 up
/ home / pi / cluster -platform linuxfb

After running this shell file the counter is started. When I run this sh script using ssh instead of the service the counter works very quickly as it should

  • 1
    "How else can I run the application?" -> You haven't really explained how you are doing it now. You mention creating a service, which if you mean an init/systemd service, is probably not the appropriate (or at least, simplest) approach for a foreground GUI application, which is to to use autologin and configure it to autostart with the desktop. – goldilocks May 1 at 19:14
  • Jessie does not run on a Pi3B+ try Stretch – Milliways May 1 at 22:11
  • I"ve edited my questnion with more informations, greetings – Sqwerize May 2 at 7:50
  • Someone can help me with my problem ? :| – Sqwerize May 3 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.