0

This I am getting an error message whenever I try to install anything through the terminal on a raspbian device. Example input:

>sudo apt-get install git

Error message:

    dpkg: error processing package chromium-codecs-ffmpeg-extra (--configure):
 package is in a very bad inconsistent state; you should
 reinstall it before attempting configuration
dpkg: dependency problems prevent configuration of chromium-browser:
 chromium-browser depends on chromium-codecs-ffmpeg-extra (= 72.0.3626.121-0+rpt4) | chromium-codecs-ffmpeg (= 72.0.3626.121-0+rpt4); however:
  Package chromium-codecs-ffmpeg-extra is not configured yet.
  Package chromium-codecs-ffmpeg is not installed.

dpkg: error processing package chromium-browser (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of rpi-chromium-mods:
 rpi-chromium-mods depends on chromium-browser (>= 65); however:
  Package chromium-browser is not configured yet.
 rpi-chromium-mods depends on chromium-codecs-ffmpeg-extra; however:
  Package chromium-codecs-ffmpeg-extra is not configured yet.

dpkg: error processing package rpi-chromium-mods (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of chromium-browser-l10n:
 chromium-browser-l10n depends on chromium-browser (>= 72.0.3626.121-0+rpt4); however:
  Package chromium-browser is not configured yet.
 chromium-browser-l10n depends on chromium-browser (<< 72.0.3626.121-0+rpt4.1~); however:
  Package chromium-browser is not configured yet.

dpkg: error processing package chromium-browser-l10n (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of scratch2:
 scratch2 depends on rpi-chromium-mods; however:
  Package rpi-chromium-mods is not configured yet.

dpkg: error processing package scratch2 (--configure):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 chromium-codecs-ffmpeg-extra
 chromium-browser
 rpi-chromium-mods
 chromium-browser-l10n
 scratch2
E: Sub-process /usr/bin/dpkg returned an error code (1)

The same error occurs when attempting to install anything at all, including installing something with pip. It seens there is an issue with chromium, but I cannot quite make any sense of the error messages.

I've also done a complete re-install of the raspbian image I am using, and the error still occurs.

  • Quote: "I've also done a complete re-install of the raspbian image I am using, and the error still occurs." What image do you use? The official supported Raspbian images are all working without errors if you don't modify them. What do you modify with your image before trying to use apt-get? – Ingo May 2 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.