3

I am having a strange error with the latest version of Raspbian. I recently upgraded from a 4gb sd card to a 16gb one and proceeded to reinstall Raspbian onto the card (I did not restore the previous system, I wanted a fresh start). On my first attempt, I got a strange error

INIT: Id "1" respawning too fast: disabled for 5 minutes

that prevented a boot. This did not go away after numerous rebootings. I did some research which yielded a few leads, but all of them involved a regular linux computer running Debian or Fedora with access to system files. Since mine wouldn't boot, I had no access to said files. The most promising lead came from the Raspberry Pi forums;

http://www.raspberrypi.org/phpBB3/viewtopic.php?f=28&t=15658

which said that a fix was to install RiscOS first (something I had done on my previous SD card) and it should work (it was not heavily detailed why this worked). Needless to say, this did not fix my problem.

This output came before the error and after it recognized the usb devices and mounted the drive, it looks relevant.

INIT: version 2.88 booting
[info] Using makefile-style concurrent boot in runlevel S.
INIT: Entering runlevel: 2
[info] Using makefile-style concurrent boot in runlevel 2.
Authentication failure
Authentication failure
Authentication failure
Authentication failure
Authentication failure
Authentication failure
Authentication failure
Authentication failure
Authentication failure
INIT: Id "1" respawning too fast: disabled for 5 minutes

One last tidbit of information, I could not get RiscOS to work right on this card either. I could boot, but there was an error when it started up and it wouldn't load at full resolution, display a desktop image, etc.

Does anybody know why this error is occuring and I can't get Raspbian to work?

UPDATE:

I think I have determined the problem, it is trying to run raspi-config but it isn't for whatever reason. raspi-config is installed at /usr/bin. The inittab file currently says,

#1:2345:respawn:/sbin/getty --noclear 38400 tty1 # RPICFG_TO_ENABLE
1:2345:respawn:/bin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1 # RPICFG_TO_DISABLE
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

which from my understanding means it is not booting directly into the Raspbian OS, it is trying to go through raspi-config first. Any ideas on why raspi-config isn't opening at boot?

And for the record I have not learned how to modify anything on my SD card, just read it.

3

INIT: Id "1" respawning too fast: disabled for 5 minutes

Wow, I haven't seen this one in years, I guess because debian is almost the last major distro left using SysV init. Technically it means there's a problem with a directive in /etc/inittab, namely the one with Id "1". It should look like this:

1:2345:respawn:/sbin/getty --noclear 38400 tty1

If it doesn't, it should (so why doesn't it)?

If it does and you are having this problem, that's bad. However, notice that it applies to runlevels 2,3,4, and 5 (see man inittab for an explanation of the syntax). You could try runlevel one. To do that, you either have to specify a boot param to the kernel, or edit /etc/inittab. You might as well do the latter. Near the top:

# The default runlevel.
id:2:initdefault:

Change 2 (or whatever number is there) to 1, put the card back in the pi and boot.

I doubt the result will be much more promising because I think the issue is with accessing the root filesystem (init can't find /sbin/getty). However, it might at least get you to a shell prompt, or provide you with some other clue.

all of them involved a regular linux computer running Debian or Fedora with access to system files. Since mine wouldn't boot, I had no access to said files.

Raspbian is a regular debian system, there's no special case here. Since anyone else with this problem would also be unable to boot, I'm not sure what you mean by them having access to files that you don't...

You do need to be able to access the SD card outside the pi, preferably with another linux system (on a live CD, in a VM, whatever). Without that, you are sort of tying one hand behind your back.

  • I thought there would be something different about Raspbian because it was written for Raspberry Pi, but I guess I was wrong. I'll take a look into changing '/inittab' with a VM (another thing I didn't know you could do) and get back to you. – qaxf6auux Sep 28 '13 at 16:38
  • The "specialness" is in the fact that it was compiled for an architecture that the mainstream linux kernel doesn't support (but that the native GNU compiler and C library do support, which is why it's all possible), and in the mechanism that boots the kernel. They've also done some other relatively minor things to tailor it, but all in all, it's a regular linux (which is an accomplishment). Hence you have other pi-centric distros which apply similar tweaks to Arch and fedora ("pidora"). – goldilocks Sep 28 '13 at 17:35
  • Well, you learn something new every day! – qaxf6auux Sep 29 '13 at 8:37
  • How do you access the etc folder with a VM? I've been trying for a while and can't figure it out – qaxf6auux Sep 29 '13 at 10:45
  • I'm actually not a windows (or VM) user. I imagine you might need to configure the VM so that it is allowed to mount the SD card. Inside the linux VM, the available card will show up in /dev as sd[X]; you'll have to determine whether it's sda or sdb, etc. There are two partitions on the card, so if it is sdb, the partitions will be sdb1 and sdb2. The first one is an ~50 MB vfat partition with the kernel and a few things in it. The second one is the root filesystem, an ext4 partition. /etc is in the toplevel of that. – goldilocks Sep 29 '13 at 14:16
3

Short Answer: Buy an SD card that is known to work for Raspberry Pi and install the latest version of Raspbian. List of working SD cards here. http://elinux.org/RPi_SD_cards


Long Answer (Untested, Hypothetical): I have a feeling that this problem stemmed from buying a really cheap, generic SD card off of eBay. It appeared to be trying to run raspi-config but for whatever reason it couldn't find it or was unable to execute it. I probably would have been able to fix it if I was able modify inittab at /etc by changing

#1:2345:respawn:/sbin/getty --noclear 38400 tty1 # RPICFG_TO_ENABLE

to

1:2345:respawn:/sbin/getty --noclear 38400 tty1

and

1:2345:respawn:/bin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1 # RPICFG_TO_DISABLE

to

#1:2345:respawn:/bin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1

However, when I tried to mount the SD card as writable on my Mac, the plugin that I was using to mount it flipped out, bricked the SD card and caused Finder to crash. With numerous attempts I could not get the card to work any more (without buying expensive software) and in a fit of rage I microwaved the card at 4am. http://www.youtube.com/watch?v=xWLqnctf9rs

Moral of the story? Buy branded SD cards.

0

i have had a issue the same with sbin/getty not being accessed while trying to boot. however my issue was with "kali linux" and not "Raspbian" although our issues seem to be the same problem just running different linux.

My solution to this problem : i put my usb in my other system, browsed through to the /sbin/getty file, copied it and pasted the "getty" file in my first partition where my boot img was and this seemed to help the system find the folder it was looking for.

maybe this could put some insight into some of your problems out there. im new to linux but pick up quick, i'm currently running the samsung chromebook arm with chrome OS and kali linux with the ctrl+U or ctrl+D to boot into kali and chrome OS. sorry for the extended response hope i helped.

0

I had the same problem in Debian Wheezy when trying to authenticate automatically the root user to start the RPI. I have initially configured the /etc/inittab file guiding me by http://elinux.org/RPi_Debian_Auto_Login:

#1:2345:respawn:/sbin/getty 38400 tty1
1:2345:respawn:/bin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
6:23:respawn:/sbin/getty 38400 tty6

This does not work, it produces the infinite error:

INIT: Id "1" respawning too fast: disabled for 5 minutes

After that, I have read a bit more about run levels at: http://www.debian-administration.org/articles/212 After that, i have tried to do something similar to Debian and Ubuntu desktop systems, where gui environment always starts in last tty, usually tty7, so i tried to do the automatic authentication in tty6 and not on tty1, using only runlevel 2 and 3. The above section of /etc/inittab was changed to:

1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
# 6:23:respawn:/sbin/getty 38400 tty6
6:23:respawn:/bin/login -f root tty6 </dev/tty6 >/dev/tty6 2>&1

After that change, everything work fine, but, i'm interested in the automatic authentication on the tty that is displayed at system initialization. To do that, i have edited the /etc/inittab file again and have changed the order in which the tty are initialized, initializing first tty6 and end the tty1.

1:2345:respawn:/sbin/getty 38400 tty6
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3
4:23:respawn:/sbin/getty 38400 tty4
5:23:respawn:/sbin/getty 38400 tty5
# 6:23:respawn:/sbin/getty 38400 tty6
6:23:respawn:/bin/login -f root tty1 </dev/tty1 >/dev/tty1 2>&1

I currently the RPI is working with this configuration without problems.

0

I had the same problem when I installed the latest version of Raspbian. I still had an older version that I downloaded in 2013. I tried to install this and it worked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.