1

Background (To give some perspective on the issue):
I am using mopidy and mopify as an audio server on a Raspberry Pi 3 B+. WHen setting this up, I found that it would not output through a USB audio device. After looking through many forum posts etc. (and a lot of trial and error) I finally got it to output to my USB audio device.

Now, I would like to output to two audio cards at once (Both the USB device and the AUX jack), and have found a way to do this using a custom Gstreamer pipeline.

The actual issue:
I must have changed something while trying to initially get the audio to default to the USB audio, and now I am unable to get an output to the AUX jack, as I cannot select card 0 (Which I think is the built-in audio card) as an audio output.

Typing in aplay -l returns:

card 1: Device [USB Audio Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

The audio menu on the top right of the desktop no longer shows HDMI or Analogue, only Bluetooth devices and USB audio. Is it possible that I have disabled card 0 somehwere?

Further Complications:
Recently I also installed mps-youtube, and found that the only player that worked was omxplayer. By default this was outputting to the AUX jack even with the issues described above. Clearly the card is still able to be accessed, and is still working, but I am unable to work out how I can play through it.

Any help would be greatly appreciated.

Edit 1 additional information:
To try and narrow down the issue, I have included the outputs of the following commands:

nat@NatsPi3:~ $ cat /proc/asound/modules
 1 snd_usb_audio
nat@NatsPi3:~ $

Looks like card 0 isn't mounted? That may not be the correct description I don't have much experience with this kind of issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.