0

I am consistently trying to connect to my RPi through SSH but the connection is refusing.

What I did is, I connect my RPi to my WiFi Router, Open Router's control panel and look into the DHCP table, enter image description here

I then opened puTTy and put this IP address as a Host name,

enter image description here

but consistently getting this error,

enter image description here

Anybody knows why I am getting this error :/ I have worked on the RPi through this process before (like a month ago) but it is not working now.

It merits mentioning that I installed, 2013-07-26-wheezy-raspbian image file on my RPi

  • Have you enabled SSH on your Raspberry Pi? – Werner Kvalem Vesterås Sep 28 '13 at 16:37
  • I am using Wheezy Raspbian, SSH is enabled by default. – Sufiyan Ghori Sep 28 '13 at 16:48
  • Have you port scanned your pi remotely, and does ssh work locally on the pi? – demure Sep 28 '13 at 17:09
  • Ok I got it fixed :) Actually, the problem was with the McAfee Antivirus, it was blocking the port 22. – Sufiyan Ghori Sep 28 '13 at 17:10
1

The problem was with the Windows Firewall, since Mcafee preventing the Firewall to establish the connection over port 22. I had to manually allow port 22 using this tutorial, http://windows.microsoft.com/en-us/windows-vista/open-a-port-in-windows-firewall

  • I just followed the instructions, couldn't connect. I created a "new Inbound rule" in advanced security. Can you list the instructions to create a Inbound rule? @Sufiyan Ghori – Giri Aug 27 '15 at 17:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.