4

NOTE: Local connection working fine, I am trying to establish a cloud connection.

I've been following the below guides to setup a cloud connection for VNC:

They both mention at some point something to the effect of:

"On your Raspberry Pi, select Licensing from the VNC Server status menu, choose Sign in to your RealVNC account, and enter your new account email and password."

But my menu does not have this Licensing option - see the screen shot below.

 - no "Licen

From what I understand from the guides - there should be a Licensing option above Check for updates.... I've checked all through the other menus and options and cannot find any way to login.

1
  • 1
    Local connection is working fine - these instructions I've quoted above are about getting the Cloud Connection working.
    – Mnlth
    May 5, 2019 at 23:19

2 Answers 2

2

I don't have the license option either. You can run vnclicensewiz to enter your license details. The the license menu appeared and the cloud option box as well. Also make sure you have Raspberry Pi Configuration Interfaces VNC set to Enable.

5
  • Thanks - I ran vnclicensewiz and logged in, tried remote and still couldn't get in - but then just did a reboot of the RaspberryPi for the changes to take effect and it worked perfectly.
    – Mnlth
    May 17, 2019 at 20:27
  • Your screenshot showed VNC was running in virtual mode. Virtual mode does not have a sign in option. To enable service mode, enable VNC with raspi-config and then reboot.
    – Botspot
    Nov 14, 2019 at 14:19
  • I tried this and it did not solve the issue. In order to get the "licensing" menu entry I had to use the raspberry pi in local mode (via monitor, keyboard and mouse) as explained by John Dunthorne. Sep 4, 2020 at 18:25
  • @ManuelDurando Just worked for me. You have to run it from within the vnc instance and it will pull up a menu to register. That is to say, start vnc server in virtual mode and log in. Open the command terminal within the virtual desktop. Type in "vnclicensewiz" and it will let you register.
    – David Reed
    Jul 23, 2021 at 9:07
  • @Botspot See my comment above.
    – David Reed
    Jul 23, 2021 at 9:07
2

I have had the same problem for days. Finally sorted it out. If you are connecting to the server in virtual mode i.e. IP Address:1 etc there is no licensing option. You need to connect directly ie with a display attached, VNC sever is then in service mode, then the option is available.

1
  • This is the correct answer. I tried using the Raspberry Pi via local monitor, keyboard and mouse and the option is finally there. Sep 4, 2020 at 18:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.