-1

I'm new to Raspberry Pi and trying to connect one to my mobile WiFi rooter. However there's an error that keeps me away from it for 10 hours. Please help me.

Initial Situation

  • Wireless & Wired Network Setting says it has "No wireless interfaces found."
  • I typed sudo raspi-config to change settings of both Wi-fi Country(I4) and WI-fi (N2), which all responded "No wireless interface found" error.

What I tried then

  • I tried ifconfig wlan0 up, which responded to me such:
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
ifup: failed to bring up wlan0
  • I've searched and some said I need changes on /etc/network/interfaces and /etc/wpa_supplicant/wpa_supplicant.conf, I've fixed each of them below:
# /etc/network/interfaces 
source-directory /etc/network/interfaces.d
auto lo

iface lo inet loopback

iface eth0 inet manual

allow-hotplug wlan0
iface wlan0 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

allow-hotplug wlan1
iface wlan1 inet manual
    wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf


# /etc/wpa_supplicant/wpa_supplicant.conf
ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1

network={
    ssid="(my rooter's SSID here)"
    psk="(Its password here)"
}

# (After these changes I've executed 'sudo reboot' already.)```

  • As I'm unable to connect it to the Wi-Fi, I cannot execute sudo apt-get update like some recommended.

I'm totally at a loss how to fix this. Please give me an advice.

Sources I've read and tried:

https://ubuntuforums.org/showthread.php?t=2346826 Cannot find device "wlan0" https://askubuntu.com/questions/249510/why-did-wlan0-device-disappear

  • 2
    What OS? What modelPi? – Milliways May 6 at 6:42
  • If you're using Raspbian and don't have country=GB (with your two char ISO country code) then the OS will call rfkill to disable the WiFi. Add that to your supplicant config file. – Dougie May 6 at 13:44
  • 1
    If you really have an RPi B+ (and not RPi 3B+), then it simply has no Wi-Fi adapter. – Dmitry Grigoryev May 6 at 13:54
-2

Question

New to Raspberry Pi trying to connect to my WiFi router.

Wireless & Wired Network Setting says it has "No wireless interfaces found.

Sudo raspi-config to change settings of both Wi-fi Country(I4) and WI-fi (N2), responded "No wireless interface found" error

Tried ifconfig wlan0 up, wpa_supplicant

Unable to connect it to the Wi-Fi, I cannot execute sudo apt-get update like some recommended

Answer

Unable to connect it to the Wi-Fi, I cannot execute sudo apt-get

I guess you are now using a networked Win PC. My first suggestion is to forget wireless WiFi for now, instead use a wired Ethernet CAT 5 cable to connect from router Ethernet port to Rpi Ethernet port. In case you don't have a spare Ethernet cable, you can consider borrowing the router/PC cable (at your own risk!).

Now you have a wired connection, then you can sudo update/ugrade, or download a new Raspbian 2019April version and install it to your Rpi.

My home setup is displayed below. I usually use another Ethernet cable to connect the router to Rpi for a wired connection. But if you have a very different setup in office or at home, you might like to show us a picture to make sure.

home wifi setup

Update 2019may07hkt1420

For Rpi2B models with built in WiFi

The suggestion above assumes you have Rpi3B+ with built in WiFi. If you have a Rpi2 without built in WiFi, then you need an external WiFi adapter/dongle and try the following steps.

  1. Download/install Raspbain image on a SD card inserted in Rpi3B+, or just use the current working SD card.

  2. Use the same SD card to boot your Rpi2, with the external WiFi adapter/dongle inserted in your Rpi2B.

rpi2b and dongle

raspbian download and setup

After booting up Rpi2B, you can use $sudo lsusb to see if your WiFi dongle has been detected.

rpi2b wifi dongle

You can give your SSID and password now. You can do it in the desktop GUI, which is easier then using terminal commands, as illustrated below.

Entering Wifi SSID and password at desktop

setting up Wifi in desktop is even easier. The steps are listed below.

Select your Wifi country (otherwise top right network icon won't work).

At top right corner, click the double red cross icon (Wifi and Ethernet).

Select to turn on your network in the list (my network name is tlfong01).

Enter password (pre shared key).

rpi2b wifi setup

Update 2019may06hkt1628

In case you have a RpiZW, then it is a bit complicated. You might like to read the following post and see if it helps.

Set up a Raspberry Pi Zero WiFi without monitor or Ethernet module

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.