1

In my Office, we have a network domain. On this network, we have a router that is connected from the network to the router using Ethernet (duh). My raspberry pi 3 A+ is connected using WiFi to this router. Now when I go on my computer which is also connected to the network using Ethernet (not thru the router just the office network domain), I can't ssh into the pi.

The raspberry pi gets a 192.168.x.x IP from the router but I know that when i connect using putty to the pi, I can't use that IP. It has it's own internal network. I tried looking into port forwarding to see if that would allow me to connect to the pi but I haven't had any luck (ssh using router ip with raspberry pi port). I am able to ping the router from my computer, its just I have no idea how to make the router pass the information to the pi.

|NETWORK| --ETHERNET--> |ROUTER| --WIFI--> |RasperryPI|

|NETWORK| --ETHERNET--> |PC| -----SSH??----------------^

Any ideas would be greatly appreciated! Thank you!

  • This is not a question belonging to Raspberry Pi. It is a question to configure the router. So I will not write an answer. You should better ask at superuser.com. Your question is very good explained but it it difficult to answer because there is nothing known about your router. On the router you may configure a bridge so that the RasPi gets part of the Office network with same ip address range. Or you have to enable routing on it (maybe an option to configure?) so that packets are routed from the office network to the private wifi network. – Ingo May 10 at 7:38
  • If you can't configure the router that way it is an option to use a second RasPi as access point instead. How to do this is indeed a question for Raspberry Pi. But there is already an answer: Setting up a Raspberry Pi as an access point - the easy way. – Ingo May 10 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.