2

I am trying to make a usb webcam work on my rpi but it drives my nuts. I have Rpi 3 model B+ Also I've downloaded the newest raspbian image (stretch with desktop and recommended software). It's updated and upgraded. At first I installed fswebcam and it worked fine until I've installed uv4l for webrtc streaming. Now my webcam just doesn't work.

enter image description here

pi@raspberrypi:~ $ lsusb
Bus 001 Device 004: ID 0513:0318 digital-X, Inc. 
Bus 001 Device 005: ID 046d:0825 Logitech, Inc. Webcam C270
Bus 001 Device 006: ID 0424:7800 Standard Microsystems Corp. 
Bus 001 Device 003: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 002: ID 0424:2514 Standard Microsystems Corp. USB 2.0 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
pi@raspberrypi:~ $ fswebcam -S 30 test.jpeg
--- Opening /dev/video0...
Trying source module v4l2...
/dev/video0 opened.
No input was specified, using the first.
Adjusting resolution from 384x288 to 352x288.
Error mapping buffer 0
mmap: No such device
Unable to use mmap. Using read instead.
--- Capturing frame...
Skipping 30 frames...
Timed out waiting for frame!
Capturing 1 frames...
Timed out waiting for frame!
No frames captured.

enter image description here

Now I can't test my webcam even with a browser.

Camera not authorized. Please check your media permissions settings.

How to repair webcam initialization?

  • Please post text, not images of text. – RalfFriedl May 9 at 19:26
  • 1
    @RalfFriedl, sorry, I've updated the post – mr.boris May 9 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.