2

I installed xscreensaver to avoid screen sleep and other interruptions, because I'm showing a feh picture presentation on a HDMI connected TV 24/7.

I managed to disable screesavers and screen blanking/sleeping/powering off but I'm getting stuck with a login screen, which appears after a few hours. The feh presentation is not visible anymore then, just the desktop background:

Lock Screen after couple of hours

I disabled screen locking in xscreensaver as well, as you can see in the configuration file. For debugging purposes I also activated xscreensavers logging in verbose mode and attached the regarding logs in the same Gist as linked above. I think it starts properly.

Are there any other components in Raspbian GNU/Linux 9, which could activate the lockscreen?

Any help is appreciated!

| improve this question | | | | |
0

I finally found the answer here: Boot to Login Screen Raspberry

you can open a terminal and type

sudo raspi-config

There you can go to

3-->Boot Options

Then

B1-->Desktop / CLI

And there you can choose:

B4-->Desktop Autologin Desktop GUI, automatically logged in as 'pi' user

After a reboot, you should access directly the desktop.

| improve this answer | | | | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.