0

I have recently bought a Raspberry Pi 3.

When it prompted me to connect to my internet I entered the password but it just displayed failed to connect. So I tried an Ethernet cable and it worked, but I want it to be wireless.

What can I do?

  • 1
    are you sure you have entered the correct ssid and password? Perhaps you can try them on your mobile phone with the same ssid and password. – tlfong01 May 10 at 13:33
  • Can you connect to the same Wi-Fi network using another device (PC, iPhone etc)? – Greenonline May 10 at 13:55
3

You can try to reconfigure WiFi. Just create a file /boot/wpa_supplicant.conf similar to this:

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev
update_config=1
country=DE

network={
    ssid="wlan@hoeft-online.de"
    psk="verySecretPassword"
    key_mgmt=WPA-PSK
}

Of course you have to use your own settings for country=, ssid= and psk=.

Then reboot and look if it works. The file should have been removed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.