0

When I use the ethernet connection on my RPi 3B+ my Archer C9 (TP-Link router) works fine for 20-30 minutes then crashes and reboots indefinitely until the RPi ethernet is disconnected. The RPi and router function normally via WiFi connection. Also there are 2 other pre-existing ethernet connections that are stable. I have tried adjusting the iptv / LAN options without success. I am at work now but have access to the log from yesterdays issues..

Things that are / were running on the pi:
Watching 720p live stream w/ OMXplayer
VNC - no active connections
Nginx server
Deluge
Pulseaudio (not currently broadcasting)
Python web scraping scripts that run hourly on 15th minute
Omxremote

2019-05-09 15:55:55 led-controller[942]: <3> 288753 Config importing failed
2019-05-09 15:55:55 led-controller[942]: <7> 288009 Failed to read WAN_ON
2019-05-09 15:55:55 led-controller[942]: <7> 288003 Led rule name is WAN_ON
2019-05-09 15:55:55 led-controller[942]: <7> 288001 Receive data length = 132
2019-05-09 15:55:55 led-controller[942]: <6> 288051 Start to run WAN1_ON
2019-05-09 15:55:55 led-controller[942]: <7> 288004 WAN1_ON is found
2019-05-09 15:55:55 led-controller[942]: <7> 288003 Led rule name is WAN1_ON
2019-05-09 15:55:55 led-controller[942]: <7> 288001 Receive data length = 132
2019-05-09 15:55:55 led-controller[942]: <6> 288051 Start to run WAN0_OFF
2019-05-09 15:55:55 led-controller[942]: <7> 288004 WAN0_OFF is found
2019-05-09 15:55:55 led-controller[942]: <7> 288003 Led rule name is WAN0_OFF
2019-05-09 15:55:55 led-controller[942]: <7> 288001 Receive data length = 132
2019-05-09 15:55:55 led-controller[942]: <6> 288051 Start to run LAN_ON
2019-05-09 15:55:55 led-controller[942]: <7> 288004 LAN_ON is found
2019-05-09 15:55:55 led-controller[942]: <7> 288003 Led rule name is LAN_ON
2019-05-09 15:55:55 led-controller[942]: <7> 288001 Receive data length = 132
2019-05-09 15:55:19 nat[8558]: <6> 211021 IPSEC ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211021 L2TP ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211021 PPTP ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211021 SIP ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211021 RTSP ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211021 H323 ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211021 TFTP ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211021 FTP ALG enabled
2019-05-09 15:55:19 nat[8558]: <6> 211024 DMZ disabled
2019-05-09 15:55:18 nat[8558]: <5> 211055 Port trigger created succeeded[trigger-port:8112 trigger-protocol:all ex-port:8112-8112 ex-protocol:all]
2019-05-09 15:55:18 nat[8558]: <7> 211002 Port triggering:trigger match 8112 and trigger relate 8112
2019-05-09 15:55:18 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:800 ip:192.168.2.126 in-port:80 protocol:all]
2019-05-09 15:55:17 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:80 ip:192.168.2.126 in-port:80 protocol:all]
2019-05-09 15:55:17 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:8081 ip:192.168.2.126 in-port:8081 protocol:all]
2019-05-09 15:55:16 qos[11117]: <6> 259504 Service start
2019-05-09 15:55:16 qos[11117]: <6> 259503 Function disabled
2019-05-09 15:55:16 qos[11117]: <6> 259505 Service stop
2019-05-09 15:55:16 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:8112 ip:192.168.2.126 in-port:8112 protocol:all]
2019-05-09 15:55:16 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:1080 ip:192.168.2.126 in-port:1080 protocol:udp]
2019-05-09 15:55:15 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:22 ip:192.168.2.126 in-port:22 protocol:all]
2019-05-09 15:55:15 upnp[10748]: <6> 217504 Service start
2019-05-09 15:55:14 upnp[10748]: <6> 217505 Service stop
2019-05-09 15:55:14 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:23 ip:192.168.2.181 in-port:22 protocol:all]
2019-05-09 15:55:13 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:8082 ip:192.168.2.181 in-port:8082 protocol:all]
2019-05-09 15:55:13 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:8114 ip:192.168.2.126 in-port:7878 protocol:all]
2019-05-09 15:55:12 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:9117 ip:192.168.2.126 in-port:9117 protocol:all]
2019-05-09 15:55:12 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:8113 ip:192.168.2.126 in-port:5050 protocol:all]
2019-05-09 15:55:11 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:5959 ip:192.168.2.181 in-port:5959 protocol:all]
2019-05-09 15:55:10 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:8080 ip:192.168.2.126 in-port:8080 protocol:all]
2019-05-09 15:55:10 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:4212 ip:192.168.2.126 in-port:4212 protocol:all]
2019-05-09 15:55:09 nat[8558]: <5> 211054 Virtual server created succeeded[ex-port:8000 ip:192.168.2.126 in-port:8000 protocol:all]
6
  • 1
    What are you doing on the Pi?
    – joan
    May 10 '19 at 16:11
  • I was watching a 720p live stream. I also have nginx and deluge on it. I have been playing with pulseaudio recently but nothing was broadcasting to the network
    – Emved
    May 10 '19 at 16:13
  • You need to edit all relevant information into the question.
    – joan
    May 10 '19 at 16:14
  • Ok added some info. I am thinking to try tonight to see if pulseaudio is causing the issue.
    – Emved
    May 10 '19 at 16:25
  • What is Archer C9? If it crashes, for what reason ever, it's not a problem of a Raspberry Pi. But that's a condition for questions on this site.
    – Ingo
    May 11 '19 at 9:39
0

So it looks like there was some program - I'm guessing it's pulseaudio but still cant pinpoint it(?) - that was making IPv6 requests and crashing the router. I tried everything to block IPv6 requests system-wide but the only thing that worked was turning activating IPv6 on my router.. not ideal but it works I suppose.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.