I'm having a similar issue from other posts but couldn't find answers, so Im asking it again. Neither Putty nor Filezilla can connect to R Pi. I already enabled SSH via raspi-config. I also created an empty file called ssh in the visible partition of the Pi. I tried to find the ip address of my Pi through the router's gateway. I also connected my Pi to a monitor and to the internet. After ifconfig, it gave the same ip address( When I tried to connect to my Pi via Putty, a connection time out error appears. If using Filezilla, I get these errors:

00:52:04 Status: Connecting to
00:52:04 Response: fzSftp started
00:52:04 Command: open "[email protected]" 22
00:52:25 Error: Network error: Connection timed out
00:52:25 Error: Could not connect to server

Update with additional information from comments:
I just installed a fresh raspian-stretch-full as of 2019-04-08.

Tried to do suggestions of the answer from @James Hurley.
#1 Remarks say "the host is unreachable"

#2 I opened sshd_config and found these lines #Port 22 #AddressFamily any ListenAddress #ListenAddress :: I tried to uncomment Port 22 but Putty cant get through. Should I reboot Pi?

#3 Only my Win laptop (wifi) and Pi(cabled) are connected to the router

#4 I saw from raspberrypi.org/forum that "Nothing is blocked on a default Raspbian installation".

#5 I think this is the only successful operation i did. it just asked the password then showed some messages. The last part is something like "Debian GNU/Linux comes ... Last login: ...

I connected my Pi to my laptop via straight cable, shared my PC's internet connection, and tried using Angry IP Scanner to determine the ip of the Pi but only my PC's ip is shown. I really think there's something wrong with the Pi. I think Im using Pi 2 since it has no wifi but has 4 usb ports, ethernet, and hdmi

How to resolve this?

  • Do you can ping from the PC?
    – Ingo
    Commented May 11, 2019 at 19:50
  • already did. response is request timed out and destination host unreachable
    – gendave
    Commented May 14, 2019 at 4:38
  • What exactly Raspberry Pi model are you using? Does it is a RPi 3B+? How does the RasPi get its ip address Do you give it a static ip address? What ip address has the router? Is it Can you ping it from the RasPi?
    – Ingo
    Commented May 14, 2019 at 10:12

1 Answer 1


A few things you can try to narrow down the problem:

  1. Use ping <IP_ADDRESS> from another computer on the same network to see if your Pi is network reachable (as suggested in the comments already). Be aware that this will send ICMP packets so just make sure that your network hardware/security software will allow these to pass; if not you'll get false negatives during testing.
  2. Double check your SSH port number in /etc/ssh/sshd_config just to make sure that it really is listening on port 22 (if not than change the port you're trying to connect on when attaching via PuTTY or FileZilla).
  3. Double check that nothing else on your network is using the same IP address as your Pi. An easy way to do this is to run a scan using the Linux nmap utility; this will return not only DHCP configured devices (as you would see in your DHCP server lease table) but also statically configured devices (easily forgotten).
  4. Probably not a concern for small networks (looks like your using 192.168.1.x\24) but just make sure you don't have any firewall rules that could cause connection errors to that IP. I've already been bitten by this myself so calling it out as a possibility.
  5. SSH into your Pi from the Pi itself. This may sound silly but the goal is just to make sure that your SSH server is properly configured and working as expected. Simply connect the Pi to a monitor and login as normal, open a terminal window, and do ssh user@ip_address. If you get prompted for credentials then succcessfully login than you know that the daemon is up, listening, and working as expected.
  • Looks like some other similar problems have been popping up with Noobs; since you didn't specify what distribution you're running I'll link this as well in case its of use: raspberrypi.stackexchange.com/questions/29209/… Commented May 12, 2019 at 14:00
  • @gendave Please don't give important additional information in comments. Instead edit your question and improve it.
    – Ingo
    Commented May 14, 2019 at 9:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.