1

Hello I have a raspberry pi 2b with xrdp installed. At home I can connect to it in rdp and ssh without any problems. The pi has the ssh and rdp ports forwarded. From another network, I can connect to it with ssh but when I want to use rdp with Remote Desktop, it says that the pi isn’t reachable. Thanks for helping Hippolyte

  • A few more details would be helpful. – RalfFriedl May 12 at 18:39
  • What would you like to know ? – Hippolyte May 12 at 18:52
  • In the client, do you get a timeout or a message similar to connection refused? On the PI, is there an access control? Have you tried a SSH tunnel for RDP? – RalfFriedl May 13 at 5:04
  • When I used the domain name, it said to use the IP so I tried to connect to my pi using the public ip. The error message was that remote desktop can't connect to the remote computer for one of these reasons... – Hippolyte May 13 at 19:30
  • i have no firewalls on the pi – Hippolyte May 13 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.