1

I am using an external sound card with my Raspberry Pi 3 Model B+. I have already disabled the default bcm2835 sound card. I have checked that the my external sound card is active. I have turned up mic and capture volume using alsamixer. When I try to record sound using arecord, the sound output file has a constant beeping sound and no other sound is picked up. I tried playing music to see if the mic captures music sound in the background and it doesn't. I tried only speaking to the mic and keeping it close while talking and it didn't work. I am not sure what's the issue here.

Any suggestions will be highly appreciated. Thanks

EDIT 1

I have tried a new sound card but still same problem. To add better context, I am adding some the details of the card and how I am trying to record:

arecord -l
**** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC295 Analog [ALC295 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: Device [USB PnP Sound Device], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Here's how I am trying to record:

arecord -r 44100 -D hw:1,0 -f S16_LE -t wav -v testR1.wav

I have also tried pulseaudio:

parecord --channels=1 -d alsa_input.usb-C-Media_Electronics_Inc._USB_PnP_Sound_Device-00.analog-mono filename.wav**strong text**

Same result unfortunately!

  • Have you tried your USB sound-card with another computer? Does the microphone work there? Is it really a microphone input or line-in? There are different type of microphones. Are you sure the microphone matches that input? – kwasmich May 16 at 9:24
  • Here's what I have tried so far: I have tried 2 different soundcard with bdshop.com/clip-microphone-boya-by-m1 this microphone. I used two sound cards to check: 1. tvc-mall.com/details/… 2. live-tech.in/sc01.php From what I gathered, both have microphone inputs. I tried using it with my laptop using arecord and parecord using the specific card hw:1,0 but, same problem. – Abrar Hossain May 16 at 10:18
  • Then the microphone does not match the input. Try another one. Usually it is simpler to use an USB microphone to avoid such pitfalls. – kwasmich May 16 at 11:34
  • Try looking through the config.txt file. There may be an option which stops audio problems. Yesterday when trying to fix my Raspberry Pi's HDMI problems I saw a few options which had to do with audio. – Roxiun May 23 at 0:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.