1

I have recently updated the software on my Pi, using SSH, and when it was done, I restarted it. I closed the PuTTY window and opened it up again, and clicked on the preset for my Pi. When it loaded, to my horror, it gave me an error: "Network Error: Permission Denied." The title of the window was, "PuTTY Fatal Error."

No big deal. Maybe the update somehow wiped out my SSH configurations that I just enabled via the raspi-config utility. (I set up a static IP using my router's settings page.) I then connected it to my TV, and enabled SSH again. When I plug it back to ethernet again, it gives me the same error.

I've seen this question: SSH "connection refused" on Raspberry pi - cannot find why, but it doesn't really help me, especially because I'm not using the terminal, nor do I think that the SSH port should change. It seems to me by the error that somehow my router blocked something.

Since my TV is far away from my router, I can't find out if it's booting correctly. It's easy to do everything I want with SSH, that is except configuring SSH, most of which you can do without internet. :P

Why isn't this working? Do I have to change a setting? Is the OS not loading correctly? It boots fine without an internet connection. (Model B, R3)

1

Check your firewall to make sure SSH is not being blocked.
If SSH was not working on the Pi, you'd get a time out error.

  • I updated the Pi, not anything else. Unless the Pi is behaving dramatically different while doing SSH, but that seems highly illogical. – Anonymous Penguin Oct 1 '13 at 22:00
  • No automatic updates got applied ? If you run a lsof -i | grep ssh on the Pi, that will tell you whether ssh is accessible. Do you have any other devices that you can use to check ssh connectivity ? Android Phone ? – Lawrence Oct 2 '13 at 2:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.