0

I’m trying to set up a ReSpeaker 2mic Pi HAT. Emphasis on trying. According to the instructions, i’m supposed to do this:

sudo apt-get update
sudo apt-get upgrade
git clone https://github.com/respeaker/seeed-voicecard.git
sudo ./install.sh

However, the minute I enter the last line into the console, I get this back:

dtparam not found
dtoverlay not found
Errors found, leaving

I’m not sure what’s going on here. The instructions don’t mention altering the config.txt until the drivers are already installed. For what it’s worth, I’ve gone in and enabled I2C and SPI, but I still get the same result. I went into the install script to see if I could figure it out, and this is the piece of code that returns the error I’m getting:

for cmd in dtparam dtoverlay ; do
  if ! which $cmd &>/dev/null ; then
    echo "$cmd not found" 1>&2
    errorFound=1
  fi
done

I don’t really know much about ssh syntax, but from what little I can parse, it’s a for loop that goes through the dtparams and overlays to find... something. Doesn’t really say what.

Any ideas? It seems that no one else has had this problem, and from what I’ve seen tech support isn’t all that helpful and and operates on Beijing time. At this point, I’m considering just commenting out the for loop.

2
  • 2
    Try actually following the instructions not leaving out steps – Milliways May 19 '19 at 4:11
  • Commenting out parts of the installation only to suppress errors will not help, of course. – Ingo May 20 '19 at 8:18
0

You can solve this by rolling back to the previous verified version, as the latest install.sh file seems to be causing this issue. Try changing your install_respeaker.sh file to the following:

#!/bin/bash

sudo apt-get update
sudo apt-get upgrade
git clone https://github.com/respeaker/seeed-voicecard.git
cd seeed-voicecard
git checkout c7026a40487a6dc751c93d3d566a4e0b5fd93442
git pull
sudo ./install.sh
sudo reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.