1

I use a script to start the google voice assistant on my rpi. This script runs fine when I run it from a terminal window, but when I try to run it via the LXDE autostartup nothing happens. It used to work, and after I ran apt-get dist-upgrade it suddenly stopped working...

I am running Raspbian 9. I couldn't find if or where the LXDE autostart creates logs to help me troubleshoot.

This is the content of my script (google_assistant_autostart.sh):

#!/bin/bash

source /home/pi/env/bin/activate

googlesamples-assistant-hotword --project_id "xxxxxxxxxx" --device_model_id "xxxxxxxxxx"$

And here's the content of the LXDE-pi autostart:

@lxpanel --profile LXDE-pi
@pcmanfm --desktop --profile LXDE-pi
@xscreensaver -no-splash
@point-rpi
@bash /home/pi/google_assistant_autostart.sh

I tried removing #!/bin/bash from my script, or @bash from the autostart, but no matter the combination, it just doesn't work.

I would greatly appreciate some help to make it work.

  • Have you tried with just @sh instead of @bash? – G Trawo May 19 at 17:42
  • I tried, no change. – Redlum May 23 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.