2

I have a Model B Raspberry Pi and an Serial Pi RS232 Interface. I am running Raspbian Wheezy on my RPi.

I configured the RPi using a Serial Guide, with particular attention to the section titled "Reconfigure the RPi console port to to be used as a standard serial port".

I used a null modem to connect a Windows PC to the RPi. The PC ran TeraTerm and the RPi ran minicom. I configured both as follows:

Baud Rate = 115200, Data Bits = 8, Parity = NONE, Stop Bits = 1, Flow Control = NONE

This worked perfectly in both directions.

I need to log the data, I assumed something like this would work:

cat /dev/ttyAMA0 > /var/log/ttyAMA0.log

But it doesn't log anything. I tried just this, and nothing is output to the screen:

cat /dev/ttyAMA0

Does anyone have any ideas or suggestions?

migrated from serverfault.com Oct 1 '13 at 14:40

This question came from our site for system and network administrators.

  • why don't you run any terminal software on Pi, where you may set up the communication parameters, like baud rate, parity and bit count? "cat" does neither of these. – lenik Oct 1 '13 at 23:46
  • Most likely minicom is getting the output of /dev/ttyAMA0 and you can't get it from cat because it's already gone. – M Noit Oct 2 '13 at 9:46
  • @lenik - I basically want to capture everything from the serial to a file. I was looking at software like ttylog, however it did not capture anything. That's when I tried cat as a basic example. – cornernote Oct 3 '13 at 6:57
  • @MNoit - I am not running minicom at the same time. Even after a clean reboot I still have the issue. – cornernote Oct 3 '13 at 6:58
3

I posted the question in RPi Forums and it was answered:

http://www.raspberrypi.org/phpBB3/viewtopic.php?f=63&t=57055&p=431581

I was able to get communications going by running this script:

https://github.com/lurch/rpi-serial-console

More technical details have been posted on the forum thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.