2

For the past few month I have been unable to use my raspberry pi because of a HDMI problem. I have tried following this guide:https://howtoraspberrypi.com/raspberry-pi-hdmi-not-working/ Only to realise I have to enable SSH first. I then got out my microSD to SD card and put it in my Mac.

I then opened up terminal and did the following commands: cd /Volumes/boot and then touch ssh and was given the output touch: ssh: Read-only file system . I then read this article: Raspberry PI config.txt gets recreated and the custom modifications ignored

Does this mean that my microSD card is worn out or is something else wrong?

Additional Info

Computer Software: Mac OS X

micro SD card: NOOBS (Although I might have accidentally reformatted it and installed a new OS)

SD Card Partitions: boot and RECOVERY

Raspberry Pi Model: Raspberry Pi Model 3 B+

diskutil list output

/dev/disk0 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *121.3 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                 Apple_APFS Container disk1         121.1 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.1 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            81.8 GB    disk1s1
   2:                APFS Volume Preboot                 44.1 MB    disk1s2
   3:                APFS Volume Recovery                522.7 MB   disk1s3
   4:                APFS Volume VM                      3.2 GB     disk1s4

/dev/disk2 (internal, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:     FDisk_partition_scheme                        *16.1 GB    disk2
   1:             Windows_FAT_16 RECOVERY                1.3 GB     disk2s1
   2:                      Linux                         33.6 MB    disk2s5
   3:             Windows_FAT_32 boot                    69.2 MB    disk2s6
   4:                      Linux                         14.7 GB    disk2s7

EDIT: I have also now changed config.txt by uncommenting #hdmi_force_hotplug=1 and #hdmi_drive=2 (This was done without SSH)

1 Answer 1

1

After reading a few more article I and checking my adaptor I realised that it was just that the switch (which until a few seconds ago I had no idea what it did) was causing the boot file to be read-only

EDIT: 1. This fixed the read only problem but as soon as I put the microSD in my RPI the SSH file was deleted.

  1. IN the end I ended up reformatting the SD and installing Raspbian Stretch and enable ssh via sudo raspi-config
6
  • You probably have other problems. The advice on creating a ssh file applies to Raspbian. NOOBS has a different partition structure and frankly is unsuitable for headless boot. The Raspbian boot parition is NOT the 1st partition on the SD Card.
    – Milliways
    May 22, 2019 at 11:20
  • @Milliways So what else would be needed to be done? I also changed #hdmi_force_hotplug=1 #hdmi_drive=2 and un-commented them without SSH. Is this a problem?
    – Roxiun
    May 22, 2019 at 11:23
  • I am not sure that creating a ssh file would even work, but if it does it would need to be in the correct partition - include the output of diskutil list in your question.
    – Milliways
    May 22, 2019 at 11:27
  • @Milliways Using cd /Volumes/boot and touch ssh it created a Unix Executable.I also changed #hdmi_force_hotplug=1 #hdmi_drive=2 and un-commented them without SSH. Is this a problem? I have also now included the output of diskutil list in the question.
    – Roxiun
    May 22, 2019 at 11:31
  • disk2s6 (which is the 2nd extended partition) looks like the Raspbian boot partition so you have edited the correct files. disk2s1 is the NOOBS boot partition. PS None of us use NOOBS (it wastes 1.3 GB of your SD Card) and it appears to have changed in how it labels partitions since I last tried.
    – Milliways
    May 22, 2019 at 11:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.