1

I have 8GB Kingston Memory card but when i am trying to Update my RPi it gives this error after 80% loading,

sudo rpi-update

enter image description here

I don't know what is happening , I have done this update before on the same SD card and it went alright. But this time it is not working. I have written the OS Image like 3 times to solve the problem, also tried 4 different SD Cards but the issue stays.

1
  • 2
    Just because you are using an 8 GB card does not mean that you have an 8 GB root filesystem -- unless you resize one, the partitions (there are two of them) in the raspbian image are < 2GB total. Post the output from the df command.
    – goldilocks
    Oct 1 '13 at 21:57
2

Did you go into raspi-config and increase the partition size? The image is of a 2GB partition. If you want the partition to fill the whole card, you need to open a terminal and type sudo raspi-config then select the option to increase the file system size. Once you've done that you should be able to update your Pi without filling the partition.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.