0

I'm using a Rpi 3 with a bridge using hostapd, dnsmasq and bridge-utils. I would like to get the IP from /var/lib/misc/dnsmasq.leases but the problem is that it shows nothing. The hotspot works fine, I can connect to the Internet via the actual rpi and an external device like a mobile phone.

These are my conf files:

/etc/dhcpcd.conf

interface wlan0
static ip_address=192.168.0.10/24
denyinterfaces eth0
denyinterfaces wlan0

/etc/network/interfaces

source-directory /etc/network/interfaces.d
auto br0
iface br0 inet manual
bridge_ports eth0 wlan0

/etc/dnsmasq.conf

interface=wlan0
dhcp-range=192.168.4.2,192.168.4.20,255.255.255.0,24h

/etc/hostapd/hostapd.conf

interface=wlan0
bridge=br0
hw_mode=g
channel=7
wmm_enabled=0
macaddr_acl=0
auth_algs=1
ignore_broadcast_ssid=0
wpa=2
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
ssid=node1
wpa_passphrase=mypassword

$ brctl show

bridge name bridge id           STP enabled interfaces
br0         8000.b827eb8691b6   no          eth0
                                            wlan0

I also use the "Network settings" of Linux Mint 19 and it perfectly creates a hotspot where the clients are well-displayed on dnsmasq.leases. The difference is that in Linux Mint I don't have a bridge but the rpi has.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.