0

sorry if the solution is obvious but this is my first time working with Linux.

Backstory (just the reason why I do this): I have to code a Programm for school which has to run on a Raspberry Pi and I have to present in my class. I've done a small smart mirror program but i made it with C#, since this is the only language I used before, now I try to get it running with Wine running in QEMU.

So I want to install dotNet4.6.1, and on the winepage nearly all test results say i need to install 4.0, on my system over Wine but I can't get it working. I've tried different Wine versions (3.0-rc6 and 3.9) and also I've tried the manual installation and the installation over winetricks. When I try to install it manually I get the following error messages:

0009:fixme:heap:RtlSetHeapInformation (nil) 1 (nil) 0 stub
0009:fixme:process:SetProcessDEPPolicy (3): stub
0009:fixme:clusapi:OpenCluster ((null)) stub!
0009:fixme:clusapi:ClusterOpenEnum (0xdeadbeef, 4) stub!
0009:fixme:clusapi:ClusterEnum (0xdeadbeef, 0, 0x33f8b0, 0x122890, 261) stub!
0009:fixme:clusapi:ClusterCloseEnum (0xdeadbeef) stub!
0009:fixme:clusapi:CloseCluster (0xdeadbeef) stub!

I have no clue where I have to look and google didn't helped me either. If I install it with Winetricks everything is getting executed correctly but in the middle then the same error messages appear and at the end it says : dotnet40 install completed, but installed file /home/pi/inet/dosdevices/c:/windows/Microsoft.NET/Framework/v4.0.30319/ngen.exe not found I'm completely lost right now and don't know where to look anymore or what it could be.

4
  • 1
    If you want to program on a Pi (which is an ARM processor) forget WINE (which is an x86 program). – Milliways May 26 '19 at 7:32
  • 1
    I got Wine running because its running in QEMU which emulates a x86 environment and I can install somethings but I can't get dotNet running – ItzCLiMB May 26 '19 at 10:37
  • 1
    QEMU is not a Pi issue, but if your aim is to get a program which runs on a Pi you are wasting your time. – Milliways May 26 '19 at 10:58
  • 1
    You might get more go out of either Mono (sudo apt-get install mono-complete) or dotnet core (look for ARM32 binaries in the SDK) for running C# code on Linux. Depends what your project will be doing. – tobyd May 26 '19 at 21:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.