0

I am completely new to the Raspberry Pi - I was bequeathed a 4yo RPi 3 and am trying to setup Kali. I have temporary access to a TV I can plug it into but will soon be leaving to go back home where I do not have TV access and will need to run the Pi Headlessly through my MacBook Pro.

My Mac OS is Mojave 10.14.5 because I'm one of those idiots that upgraded.

Background: I have already downloaded the newest Kali ARM image from here which is version 2019.2 and flashed it to an SD card using the dd commands you see in a lot of tutorials. I was able to hook the Pi up to my TV and it boots fine. I followed the instructions here to setup SSH and get an 'active" status when I run sudo service ssh status as desired.

Problem: When I hook my Pi to my MacBook I do so through an Ethernet cord which connects to the Pi like this: Pi Ethernet -> Ethernet to USB adaptor -> USB to USBc adaptor -> MacBook.

I currently have Internet Sharing turned off although I have tried this with internet sharing turned on and ultimately WOULD like my MacBook Wifi to be shared with the Pi over their connect. Regardless, with Internet Sharing off my network connection looks as below. The ethernet Configure IPv4 setting is set to "Using DHCP" and it says it has a self-assigned IP address and will not be able to connect to the Internet. I believe the IP address assigned to it is a link-local address and this should NOT be a problem for SSHing.

network settings

However, when I try to SSH into the Pi with the following command (I have not changed the default username (root) or password (toor)) using the listed IP address: ssh root@169.254.58.14 I get the following output where it first looks like it asks me for a system password and then the Pi's password. I have tried inputting my system password and 'toor' for both but have only ever gotten the given output.

ssh results

Things I have tried: Like previously mentioned I have tried turning Internet Sharing both on and off. I have tried setting a manual/static IP address in the network options. I have tried setting the static IP address to 192.168.1.11 when the "wifi" IP address is 192.168.1.10. The latter option makes the status of the ethernet change to "Connected" but I still get the same results when trying to SSH.

I'm really struggling because like I said, my Pi is right out the (4yo) box and I know nothing about networking and at this point I have spent a day and a half on this and I don't know what to do. Can someone point me in the right direction?

  • Possible duplicate of How do I set up networking/WiFi/static IP address? – Milliways May 28 at 0:20
  • I don't know about Kali, but Raspbian doesn't have a root account, and generally LInux does not permit ssh as root – Milliways May 28 at 0:23
  • Why are you using Kali, it is not for someone inexperienced in networking? Install Raspbian following the Foundation tutorials – Milliways May 28 at 0:26
  • It's my attempt to learn about networking, actually. I'm trying to set myself,f up for success since I find pen testing interesting and I'm trying to avoid quitting by boring myself. As to the link I actually have tried to set a static IP address as per the tutorial here: charlesreid1.com/wiki/Kali_Raspberry_Pi/… but got the same results as above. It's tricky to work with Raspbian tutorials because there are files for Raspbian that aren't in the Kali distro that can be edited as required. But I will definitely look further at the link. – chainhomelow May 28 at 0:34
  • Just took a quick look at the link; the author doesn't seem to understand the difference between a Link-local address and static. The cmdline.txt listed is obsolete, and won't work on PI3. Other sugestions are also obsolete. – Milliways May 28 at 1:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.