1

I have the following setup

Raspberry pi with samba installed and running

Windows 8 machine that can see the samba share, access the proper DIR, see all contents

In the smb.conf file, at the base of the file, I created the above dir with this

[AirLock]
comment = AirLock
path = /thepath/
writeable = Yes
create mask = 0777
directory mask = 0777
browseable = Yes
public = Yes
read only = no

With these settings I can see the whole dir that I want but I cant create files, edit files, or create DIRs.

closed as off-topic by lenik, Impulss, syb0rg, SteveIrwin, Jacobm001 Dec 30 '13 at 21:18

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question does not appear to be specific to the Raspberry Pi within the scope defined in the help center." – lenik, Impulss, syb0rg, SteveIrwin, Jacobm001
If this question can be reworded to fit the rules in the help center, please edit the question.

1

Did you add the user password to the Samba password file? You can do this with this command:

smbpasswd -a pi

If this command isn't found, run

sudo apt-get install samba-common-bin

and then try the previous command again.

Also, change public to 'no' and restart Samba. When you connect from your Windows machine, you'll be prompted for pi's username and password. Setting it up this way means Samba knows you're not an anonymous user, so it gives you the access rights of user pi.

1

The problem ended up being the dir permissions

They were restrictivly set

It had nothing to do with samba

sudo chmod -R 0777 "/theDirIwantToAccess/"

This will fix this problem

  • This may work but creates a large security hole; in general world writable directories and files are a mistake. While it works it is not really the right way to do it. – Steve Robillard Jan 1 '14 at 8:11

Not the answer you're looking for? Browse other questions tagged or ask your own question.